Search found 131 matches

by mrdebug
Fri Apr 08, 2016 6:21 am
Forum: wxCode
Topic: [Solved] wxChartPanel error on create
Replies: 2
Views: 1241

[Solved] wxChartPanel error on create

This line of code
wxCPFatturato= new wxChartPanel(wxPGrafico);
Where wxPGrafico is a wxPanel, causes this error:
../src/gtk/bitmap.cpp(541): assert ""width > 0 && height > 0"" failed in Create(): invalid bitmap size
This happens with the last wxWidgets library. How can I resolve the problem?
by mrdebug
Wed Apr 06, 2016 1:20 pm
Forum: C++ Development
Topic: [Solved] wxWidgets 3.1.0, problem with ini files
Replies: 1
Views: 340

Re: wxWidgets 3.1.0, problem with ini files

Solved by changing the linked libraries list.
by mrdebug
Wed Apr 06, 2016 1:20 pm
Forum: C++ Development
Topic: [Solved] wxWidgets 3.1.0, problem with bmp image
Replies: 1
Views: 282

Re: wxWidgets 3.1.0, problem with bmp image

Solved by changing the linked libraries list.
by mrdebug
Wed Apr 06, 2016 11:18 am
Forum: C++ Development
Topic: [Solved] wxWidgets 3.1.0, problem with ini files
Replies: 1
Views: 340

[Solved] wxWidgets 3.1.0, problem with ini files

Using wxWidgets 3.1.0 now I have an error when I try to load and save a ini file in the executable folder. The error is this: Changes won't be saved to avoid overwriting the existing file "" X: can't read from file descriptor 3 (error 0: operazione completata.) X: can't close file descriptor 3 (erro...
by mrdebug
Wed Apr 06, 2016 11:11 am
Forum: C++ Development
Topic: [Solved] wxWidgets 3.1.0, problem with bmp image
Replies: 1
Views: 282

[Solved] wxWidgets 3.1.0, problem with bmp image

After porting a wxwidgets 3.0.2 program to 3.1.0 (on Windows) now I have a problem with the bmp images. The program goes to crash when I try to load them. The line where the program goes to crash is this: wxImage Image(wxT("C:\\Cpp\\wxTrazioni\\wxTrazioni.bmp"), wxBITMAP_TYPE_BMP); All works well wi...
by mrdebug
Mon Mar 28, 2016 9:04 am
Forum: C++ Development
Topic: wxGrid wxWidgets 3.1
Replies: 1
Views: 366

Re: wxGrid wxWidgets 3.1

Solved by adding adv xml core
by mrdebug
Mon Mar 28, 2016 8:58 am
Forum: C++ Development
Topic: wxGrid wxWidgets 3.1
Replies: 1
Views: 366

wxGrid wxWidgets 3.1

I'm trying to build a program on Debian 8 64 bit using wxWidgets 3.1. On linking I obtain this error undefined reference to symbol '[email protected]@WXU_UNOFFICIAL_3.1'| related to these lines of code new wxGridCellBoolRenderer() new wxGridCellBoolEditor() And this error undefined refer...
by mrdebug
Mon Mar 28, 2016 8:37 am
Forum: wxCode
Topic: [Solved] Build wxFreeChart in Debian 8 64
Replies: 2
Views: 3409

Re: Build wxFreeChart in Debian 8 64

Solved by adding -lwx_gtk2u_unofficial_adv-3.1 to the key WX_LIBS
by mrdebug
Sun Mar 27, 2016 3:54 pm
Forum: wxCode
Topic: [Solved] Build wxFreeChart in Debian 8 64
Replies: 2
Views: 3409

[Solved] Build wxFreeChart in Debian 8 64

I'm trying to build wxFreeChart in Debian 8 64 bit but i obtain this error: wxcode_gtk2u_freechart-3.1 -L/usr/lib/x86_64-linux-gnu -pthread -lwx_gtk2u_unofficial_core-3.1 -lwx_baseu_unofficial-3.1 -lwx_gtk2u_unofficial_aui-3.1 /usr/bin/ld: wxFreeChartDemo_dll_demo.o: undefined reference to symbol '_...
by mrdebug
Sun Mar 27, 2016 3:52 pm
Forum: C++ Development
Topic: [Solved] class wxGrid has no member named GetCols
Replies: 1
Views: 280

[Solved] class wxGrid has no member named GetCols

Is there a way to get the column count of a wxGrid? The GetCols() functions seems to be removed in the last wxWidgets version.
by mrdebug
Fri Oct 09, 2015 8:05 am
Forum: C++ Development
Topic: wxPreviewFrame modal
Replies: 0
Views: 862

wxPreviewFrame modal

Is there a way to have wxPreviewFrame showing in modal mode?
by mrdebug
Fri Dec 19, 2014 8:28 am
Forum: General Development
Topic: Ado support
Replies: 0
Views: 641

Ado support

In order to use Ado I need to use the struct IDBInitialize, stored in the header file oledb.h but there isn't this header file in my MinGW include dir. Can anyone suggest me the way to have it?
by mrdebug
Tue Dec 09, 2014 9:23 pm
Forum: C++ Development
Topic: Problem with wxString::Replace
Replies: 1
Views: 800

Problem with wxString::Replace

This line of code
wxString wxSTemp;
...
wxSTemp.Replace(wxString("€"), wxString(""));
works on Windows but on Linux I obtain the error
../src/common/string.cpp(1404): assert "!strOld.empty()" failed in Replace(): wxString::Replace(): invalid parameter

Do you know why?
by mrdebug
Wed Dec 03, 2014 9:58 am
Forum: C++ Development
Topic: How do I properly load images from resource?
Replies: 14
Views: 3025

Re: How do I properly load images from resource?

I don't now but, how do you manage the resource file?
Can you suggest me a crossplatfrom resource file editor?
by mrdebug
Thu Nov 27, 2014 6:35 pm
Forum: C++ Development
Topic: wxThread and main gui
Replies: 7
Views: 971

Re: wxThread and main gui

Ok, thanks for advice.
Are you a wxWidgets developer? Maybe is a good idea to implement a synchronized way to call main gui functions.