Search found 41 matches

by fishnet37222
Fri Sep 08, 2017 4:39 am
Forum: Platform Related Issues
Topic: wxWebView refuses to build on Linux
Replies: 3
Views: 802

wxWebView refuses to build on Linux

I'm trying to build wxWidgets 3.1.0 on Linux Mint 18.2 using version 5.4 of GCC. I've installed the libwebkit2gtk-4.0-dev package since I'm building the library with support for GTK3. The configure and make commands complete without any errors, but there is no webview library in the libs folder. Bel...
by fishnet37222
Mon Sep 04, 2017 4:15 pm
Forum: Platform Related Issues
Topic: Compilation errors when trying to use wxWebView on Windows 10
Replies: 3
Views: 668

Re: Compilation errors when trying to use wxWebView on Windows 10

I added the required library as an explicit linker input and it compiled without any errors, but I was expecting the linker to search all the libraries in the library directories.
by fishnet37222
Mon Sep 04, 2017 3:47 pm
Forum: Platform Related Issues
Topic: Compilation errors when trying to use wxWebView on Windows 10
Replies: 3
Views: 668

Compilation errors when trying to use wxWebView on Windows 10

I'm trying to use a wxWebView control to display the license for the program I'm writing. I'm getting the following compilation errors. I'm using wxWidgets 3.1.0 with Visual Studio 2017 on Windows 10. 1>------ Build started: Project: FNDice, Configuration: Debug x64 ------ 1>AboutDialog.cpp 1>AboutD...
by fishnet37222
Sun Sep 03, 2017 4:36 pm
Forum: C++ Development
Topic: How to span radio button group across multiple containers
Replies: 1
Views: 446

How to span radio button group across multiple containers

In the screenshot below you'll see that I have a set of radio buttons inside a single wxStaticBox. I have nested two wxPanels inside the box in order to have the controls on the left take up the same amount of space as the controls on the right. According to standard UX rules, when one of the radio ...
by fishnet37222
Sun Sep 03, 2017 12:18 am
Forum: Platform Related Issues
Topic: Toolbar tools are not showing on Windows
Replies: 1
Views: 673

Toolbar tools are not showing on Windows

wxWidgets 3.1.0, Visual Studio 2017, Windows 10. I am attempting to add a toolbar to a window. The toolbar gets added, but for some reason the tools are not showing. This only seems to happen on Windows. I am using XPM files for the toolbar button icons. I used the code below to set-up the toolbar. ...
by fishnet37222
Wed May 24, 2017 12:36 am
Forum: Platform Related Issues
Topic: Background window not receiving close event (Windows 10)
Replies: 3
Views: 747

Re: Background window not receiving close event (Windows 10)

Yes, I do observe the same behavior with the Minimal sample. I can, however, confirm that the issue does not occur on Windows 7.

Here is the exact version of Windows 10 that I'm using:
2017-05-23_20-34-54.png
2017-05-23_20-34-54.png (8.49 KiB) Viewed 721 times
by fishnet37222
Tue May 23, 2017 10:48 am
Forum: Platform Related Issues
Topic: Background window not receiving close event (Windows 10)
Replies: 3
Views: 747

Background window not receiving close event (Windows 10)

I'm writing an app on Windows 10 using Visual C++ 2017 and wxWidgets 3.1.0. I've noticed that if my app doesn't currently have focus and I try to use the close button on the window's taskbar thumbnail, the close event doesn't get processed until I make that window active. In the screenshot below, th...
by fishnet37222
Wed May 17, 2017 1:09 am
Forum: Platform Related Issues
Topic: Trouble loading multiple size ICO embedded resource
Replies: 8
Views: 2008

Re: Trouble loading multiple size ICO embedded resource

Thanks for the replies guys. Once I modified my .rc file to remove all the extra stuff that Visual Studio added and put "#define wxUSE_NO_MANIFEST 1" at the top, PB's solution worked like a charm.
by fishnet37222
Tue May 16, 2017 11:17 am
Forum: Platform Related Issues
Topic: Trouble loading multiple size ICO embedded resource
Replies: 8
Views: 2008

Trouble loading multiple size ICO embedded resource

I'm using wxWidgets 3.1.0 on Windows 10 using Visual C++. I have a multiple size .ico file included as a resource in my project. I'm using the following code to set my frame's icon in the constructor. wxInitAllImageHandlers(); this->SetIcon(wxICON(IDI_ICON1)); The code compiles and runs without any ...
by fishnet37222
Sun May 07, 2017 4:19 pm
Forum: C++ Development
Topic: Escaped unicode character not displaying properly
Replies: 1
Views: 487

Escaped unicode character not displaying properly

Hello, I have the following code in the event handler for a toolbar button's click event handler: wxUnusedVar(event); wxAboutDialogInfo info; info.SetName("FNDice"); info.SetCopyright(_("v1.0b. Copyright \u00A9 David Frischknecht")); info.SetLicence(_("GPL v2")); info.SetDescription(_("The tradition...
by fishnet37222
Sat May 06, 2017 1:57 pm
Forum: C++ Development
Topic: Custom wxWindow paint event not called.
Replies: 1
Views: 482

Custom wxWindow paint event not called.

Hello, I'm just learning wxWidgets and I'm facing an issue with a custom control I'm creating that's derived from wxWindow. I've created a method to handle the wxEVT_PAINT event, but it doesn't seem to be called. I set a breakpoint on the first line of paintEvent(), but it doesn't break. I'm using t...