Search found 113 matches

by Ugly!
Tue May 08, 2007 1:32 pm
Forum: General Development
Topic: Update configuration files for my app. Need strategy
Replies: 2
Views: 682

What kind of changes are between each version? Are the configuration parameters changed? New options added? One important question is: Why are the configuration files changing so often? The approach I can give is not to convert directly the config files on update but to be able to open them and pars...
by Ugly!
Sat May 05, 2007 10:09 pm
Forum: wxCode
Topic: ANN: wxActiveRecordGenerator 1.2.0 rc1 released
Replies: 2
Views: 888

Hello. :) Just tried wxARG-1.2.0-rc2 with SQLite3 database and wxARG crahes after generating the source code from first table. I submitted a bugreport but just to double confirm, I submit database file and wxARG project file here. Regards, T-Rex Hi, T-Rex. I've got the bur report via wxCode mail li...
by Ugly!
Wed Apr 18, 2007 5:04 pm
Forum: wxCode
Topic: ANN: wxActiveRecordGenerator 1.2.0 rc1 released
Replies: 2
Views: 888

ANN: wxActiveRecordGenerator 1.2.0 rc1 released

wxActiveRecordGenerator 1.2.0 rc1 has been released. wxActiveRecordGenerator is an application that connects to a database and generates c++ classes to interact with tables. You can also specified how the active records relate. This component depends on the DatabaseLayer component at wxCode. So all ...
by Ugly!
Wed Apr 18, 2007 4:57 pm
Forum: Announcements and Discoveries
Topic: [ANN] wxActiveRecordGenerator 1.2.0 rc1 released
Replies: 8
Views: 1291

jb_coder wrote:Congratulations on the release! I look forward to pulling it down over the weekend.
Thank you! Please, let me know if you see anything that can be improved or fixed...

Regards, Mat
by Ugly!
Fri Apr 13, 2007 12:15 pm
Forum: Announcements and Discoveries
Topic: [ANN] wxActiveRecordGenerator 1.2.0 rc1 released
Replies: 8
Views: 1291

priyank_bolia wrote:Does any body knows a tutorial for DatabaseLayer
I don't, but it's not that difficult if you look at the samples and know your SQL.
You can also consult the Doxygen files on the DatabaseLayer documentation.

Regards,
Matias
by Ugly!
Fri Apr 13, 2007 11:19 am
Forum: Announcements and Discoveries
Topic: [ANN] wxActiveRecordGenerator 1.2.0 rc1 released
Replies: 8
Views: 1291

[ANN] wxActiveRecordGenerator 1.2.0 rc1 released

wxActiveRecordGenerator 1.2.0 rc1 has been released. http://wxcode.sourceforge.net/components/activerecord/ wxActiveRecordGenerator is an application that connects to a database and generates c++ classes to interact with tables. You can also specified how the active records relate. The component dep...
by Ugly!
Mon Apr 02, 2007 7:47 pm
Forum: wxDev-C++
Topic: Databaselayer - Error when opening the databse.
Replies: 2
Views: 637

Please try to catch the exception so you may have some information about the error. #include "DatabaseLayerException.h" void Projeto1Dlg::WxButton1Click(wxCommandEvent& event) { wxString dsn; dsn = "BdTeste"; try{ DatabaseLayer *db; db = new OdbcDatabaseLayer(); db->Open(dsn, wxEmptyString, wxEmptyS...
by Ugly!
Thu Mar 08, 2007 7:52 am
Forum: wxDev-C++
Topic: is there a problem adding wxPanel to wxNoteBook in wn XP
Replies: 7
Views: 879

traltixx wrote:Okay, I've isolated and solved the problem on my own. But i'd like an explanation to my previous questions.
Maybe if you post the solution or what you've change would be easier.

Don't be afraid to share :wink:
by Ugly!
Wed Mar 07, 2007 7:48 am
Forum: wxDev-C++
Topic: is there a problem adding wxPanel to wxNoteBook in wn XP
Replies: 7
Views: 879

Mmm...some code might be useful here...
Hw are you creating and adding the panels to the notebook? Can you post that?
by Ugly!
Wed Mar 07, 2007 7:26 am
Forum: C++ Development
Topic: Error C:\wxmsw2.8.0\include\wx\dynarray(813)
Replies: 1
Views: 339

Eh? How about some code? Where does your application crashes? What is the call stack? This problem happens when you try to access an Item in an overbounded index. Thus "uiIndex < m_nCount": the index passed to Item() must always be < the number of items in the array.
by Ugly!
Wed Mar 07, 2007 6:11 am
Forum: C++ Development
Topic: wxTextValidator problems
Replies: 2
Views: 483

First of all: void Dlg_NewMap::Btn_AcceptClick(wxCommandEvent& event) { if (Validate() && TransferDataFromWindow()) { EndModal(wxID_OK); //USE wxID_OK, and compare ShowModal() to it } } Second: I think that the space character is not a valid alphanumeric for the wxFILTER_ALPHANUMERIC filter. And if ...
by Ugly!
Fri Mar 02, 2007 5:12 am
Forum: Platform Related Issues
Topic: wxPrintf in Unicode
Replies: 2
Views: 654

The DOS windows does not support Unicode characters AFAIR.
And changing the code page with >chcp 65001 (which is supossed to be the utf-8 code page) won't make a difference in my experience.

You can try using the Lucida Console font and doing "chcp 1252" before running your program.

Regards, Mat
by Ugly!
Thu Mar 01, 2007 8:08 pm
Forum: C++ Development
Topic: Newbie Unicode question - Is this ok?
Replies: 9
Views: 1059

Code::Blocks is an excellent IDE, and allows you to change the encodings that the files are opened in. JS But I don't know where the problem is. Is it the IDE or the compiler? I'm guessing the compiler is the one that should support different source files encoding. I'll give it a try any way... Thn...
by Ugly!
Thu Mar 01, 2007 8:11 am
Forum: C++ Development
Topic: Newbie Unicode question - Is this ok?
Replies: 9
Views: 1059

Just confirming that studio 2005 handles unicode char in source files seamlessly. But I failed to display them, when run. Says, cant display in current codepage. It was my test program's fault i believe not MS's. al Sorry, I didn't understand. Would you care to elaborate please? How are you using t...
by Ugly!
Wed Feb 28, 2007 11:22 pm
Forum: C++ Development
Topic: Newbie Unicode question - Is this ok?
Replies: 9
Views: 1059

I would have expected Visual C++ to handle Unicode characters entered in the IDE out of the box, but it's possible that changing the encoding will help. -Gerald Visual C++ 2005 Express Ed. does not seem to handle different encodings. Actually, you cannot set the source file encoding anywhere at all...