Search found 31 matches

by jbattle
Wed Feb 06, 2019 7:22 am
Forum: Platform Related Issues
Topic: [OSX] OnChar repeat action not working for some keys?
Replies: 3
Views: 346

Re: [OSX] OnChar repeat action not working for some keys?

I did post in the other forum, and ended up figuring out the problem after playing the samples/text application. Although I posted the answer there, I'm posting a short version of it here in case someone searches and finds this forum. OS X has a feature where holding down a key with a long press wil...
by jbattle
Tue Feb 05, 2019 7:21 pm
Forum: Platform Related Issues
Topic: [OSX] OnChar repeat action not working for some keys?
Replies: 3
Views: 346

Re: [OSX] OnChar repeat action not working for some keys?

ONEYEEMAN,

My list of characters didn't mean to imply that none of the upper case characters came though. It was saying only those keys worked (eg, c and C both repeat, i and I, etc), I didn't see the point of listing both, but now I see it wasn't clear.

I'll try the other forum too.

Thanks
by jbattle
Sun Feb 03, 2019 7:25 am
Forum: Platform Related Issues
Topic: [OSX] OnChar repeat action not working for some keys?
Replies: 3
Views: 346

[OSX] OnChar repeat action not working for some keys?

In my application (an old computer emulator), holding down most keys results in a repeated OnChar event. That all works on wxwin, but on wxmac, only some keys repeat! I could understand of had some menu shortcut keys mapped or something, but that isn't the case. I then ran the samples/keyboard appli...
by jbattle
Tue Jan 22, 2019 4:33 pm
Forum: Compiler / Linking / IDE Related
Topic: Compiling wxWidgets 3.1.2 on macOS Mojave
Replies: 17
Views: 1402

Re: Compiling wxWidgets 3.1.2 on macOS Mojave

The command started with "../configure" That is the thing complaining about the options is a script that is part of the wxWidgets release. Did you perhaps just type "configure blah blah blah" and there is a different configure somewhere on your search path? [EDIT] From the same directory where you r...
by jbattle
Sat Jan 19, 2019 6:50 am
Forum: Platform Related Issues
Topic: sound sample doesn't work right, osx mojave
Replies: 7
Views: 369

Re: sound sample doesn't work right, osx mojave

I've studied the code a bit more. wxWidgets is using the system sound services set of APIs (https://developer.apple.com/documentation/audiotoolbox/system_sound_services) for implementing the wxSound API on OSX. This is a very simple but very limited API. As a result, the stuff I was jibbering about ...
by jbattle
Sat Jan 19, 2019 1:23 am
Forum: Platform Related Issues
Topic: sound sample doesn't work right, osx mojave
Replies: 7
Views: 369

Re: sound sample doesn't work right, osx mojave

That took less time to confirm that I expected. I generated a 0.5 second audio sample, just a 1Khz tone, as a wav file. When I load it using the sound sample program and play it in a loop, there is a gap between each iteration of the loop. So I don't think that the sound is just too short, I think t...
by jbattle
Sat Jan 19, 2019 1:06 am
Forum: Platform Related Issues
Topic: sound sample doesn't work right, osx mojave
Replies: 7
Views: 369

Re: sound sample doesn't work right, osx mojave

I did make the change and the sound sample works now. I downloaded wxwidgets as a zip file and don't have a repository set up. So to send a patch back I'll need to do that and learn enough git to make it happen. (that is the end of the useful information. below is just details about why, even with t...
by jbattle
Fri Jan 18, 2019 7:46 am
Forum: Platform Related Issues
Topic: sound sample doesn't work right, osx mojave
Replies: 7
Views: 369

Re: sound sample doesn't work right, osx mojave

I believe I understand what is going wrong. I have no experience developing on OSX, but just looking at src/osx/core/sound.cpp was enough. I have not tested a fix. The call to Create() obtains a handle for the sound resource. This is saved in the wxOSXAudioToolboxSoundData class as m_soundID. In DoS...
by jbattle
Sun Jan 13, 2019 4:21 am
Forum: Compiler / Linking / IDE Related
Topic: Compiling wxWidgets 3.1.2 on macOS Mojave
Replies: 17
Views: 1402

Re: Compiling wxWidgets 3.1.2 on macOS Mojave

I just upgraded a mac mini to mojave and built installed wx-3.1.2. My script to build is: mkdir debug cd debug ../configure \ --disable-shared \ --enable-stl \ --with-cxx=14 \ --with-macos-sdk=/Library/Developer/CommandLineTools/SDKs/MacOSX10.14.sdk \ --enable-debug \ --enable-debug_gdb \ --disable-...
by jbattle
Sun Jan 13, 2019 1:46 am
Forum: Platform Related Issues
Topic: sound sample doesn't work right, osx mojave
Replies: 7
Views: 369

sound sample doesn't work right, osx mojave

I have my application running fine on windows, and I'm just now getting it working for OSX. I was having problems with wxSound, so my first course of action was to build the samples/sound program, completely unmodified. It was built using the developer command line tools (that is, apple's faux gcc, ...
by jbattle
Tue Feb 21, 2012 6:39 pm
Forum: C++ Development
Topic: Looking for a SVG renderer
Replies: 10
Views: 3773

Re: Looking for a SVG renderer

I wasn't able to find the wxsvg forum before, but eventually I did, so I've posted my question there, as it is a more specific forum: http://sourceforge.net/projects/wxsvg/forums/forum/424987/topic/5050296 Either way, I'm still in the dark. It is a shame -- it seems like a lot of work went into crea...
by jbattle
Sun Feb 19, 2012 5:19 am
Forum: C++ Development
Topic: Looking for a SVG renderer
Replies: 10
Views: 3773

Re: Looking for a SVG renderer

Short version: How does one build wxsvg using msvc++? Longer version: I have written an emulator for an obscure old computer, and I hacked up a rough UI using standard wx controls. Now I want to polish the interface to look as much like the real front panel as I can. Using fiverr.com, I found someon...
by jbattle
Sat Jan 07, 2012 1:48 am
Forum: Compiler / Linking / IDE Related
Topic: Fixed wxWidgets 2.9.1 project files Visual Studio 2010
Replies: 12
Views: 26561

Re: Fixed wxWidgets 2.9.1 project files Visual Studio 2010

doublemax, thanks for the help. I had followed the directions from somewhere saying I should open build/msw/wx.dsw which barfed hard, then I tried these 2.9.1 files.

As you say, opening wx_vc9.sln worked.
by jbattle
Fri Jan 06, 2012 11:22 pm
Forum: Compiler / Linking / IDE Related
Topic: Fixed wxWidgets 2.9.1 project files Visual Studio 2010
Replies: 12
Views: 26561

Re: Fixed wxWidgets 2.9.1 project files Visual Studio 2010

I'm seeing the exact same problem kadesh reported on 2010/11/13, after trying to build Debug and Release library versions of wx 2.9.3. I realize this zip file wa smade for 2.9.1, but without it, msvc 2010 express wouldn't even try to build anything, complaining that it couldn't convert any of the bu...
by jbattle
Fri Nov 21, 2008 10:55 pm
Forum: Platform Related Issues
Topic: compiling for 10.3.9 -- can't find std::string
Replies: 3
Views: 866

frank_frl -- I'm not talking about building my app yet, just getting wx widgets built for 10.3.9. To be more explicit, if I try and build the wx library like this, it fails: mkdir build-debug cd build-debug ../configure \ --enable-universal_binary \ --disable-shared \ --disable-compat26 \ --enable-s...