Search found 18 matches

by Zeal
Fri Oct 19, 2007 5:56 pm
Forum: C++ Development
Topic: The "main loop"
Replies: 12
Views: 4243

Nope still no answer.. kinda given up in favor of a temporary alternative gui solution. Although someday ill come back to wx, so if anyone has an answer I would still love to hear it!
by Zeal
Wed Sep 26, 2007 9:02 am
Forum: C++ Development
Topic: The "main loop"
Replies: 12
Views: 4243

Took a break for awhile (focused on non gui things), but now im at a point where im ready to implement wxWidgets, but I still have this 'main loop' prooblem. I did a forum search and all I could find was a possible solution using wxTimer()? Doesnt seem right... Is there no way to just pump the dang ...
by Zeal
Fri Jun 29, 2007 12:00 pm
Forum: C++ Development
Topic: The "main loop"
Replies: 12
Views: 4243

Cool thanks for the info about wxTheApp, but sounds like its not enough... Im sure this has to be possible... but how!?
by Zeal
Tue Jun 26, 2007 1:24 am
Forum: C++ Development
Topic: The "main loop"
Replies: 12
Views: 4243

Ok cool that looks like just what I need. But where am I getting the 'app' from? All i am doing is calling wxInit()/wxUninit(). At what point should I be 'making' the app object?
by Zeal
Mon Jun 25, 2007 12:35 am
Forum: C++ Development
Topic: The "main loop"
Replies: 12
Views: 4243

Well I found.. // ---------------------------------------------------------------------------- // main event loop implementation // ---------------------------------------------------------------------------- int wxAppBase::MainLoop() { wxEventLoopTiedPtr mainLoop(&m_mainLoop, new wxEventLoop); retu...
by Zeal
Sat Jun 23, 2007 8:29 am
Forum: C++ Development
Topic: The "main loop"
Replies: 12
Views: 4243

I thought about putting wx in its own thread, but im still unsure how write the 'message pump'. For example, when I write a simple 'single window' app, I include a little message pump that translates windows messages so the window can be moved, resized, ect... MSG winmsg; while ( PeekMessage( &winms...
by Zeal
Sat Jun 23, 2007 1:55 am
Forum: C++ Development
Topic: The "main loop"
Replies: 12
Views: 4243

The "main loop"

Im a little fuzzy on the whole IMPLEMENT_APP concept. It seems like when I use that, wx is running its own internal main loop, which makes me wonder how im supposed to include MY main loop (which is unrelated to wx). So, how can I still have control over my own main loop, and also init/pump/unit wx ...
by Zeal
Mon Jun 04, 2007 11:42 am
Forum: Compiler / Linking / IDE Related
Topic: Unresolved External 'wxString' ONLY in debug mode
Replies: 20
Views: 3588

Wohoo thanks dsilvia its working now! For anyone who is curious, I needed to change the character set to 'not set', that seemed to do it.

*hmm I think I screwed up the 'accept answer' thing.. I was hoping to give dsilvia some "Super Happy Magic Wx Points" :(
by Zeal
Mon Jun 04, 2007 8:29 am
Forum: Compiler / Linking / IDE Related
Topic: Unresolved External 'wxString' ONLY in debug mode
Replies: 20
Views: 3588

Project sent (thanks again!)
by Zeal
Mon Jun 04, 2007 8:14 am
Forum: Compiler / Linking / IDE Related
Topic: Unresolved External 'wxString' ONLY in debug mode
Replies: 20
Views: 3588

Hmm ok this is strange. I copied the entire list of 'debug' libs to my dependencies. Now im getting a .. LINK : fatal error LNK1104: cannot open file 'wxbase28d.obj' But I have the correct path added to my Linker-General-AdditionalDir. Im even looking at the file now, wxbase28d.obj is in fact there....
by Zeal
Mon Jun 04, 2007 7:51 am
Forum: Compiler / Linking / IDE Related
Topic: Unresolved External 'wxString' ONLY in debug mode
Replies: 20
Views: 3588

Well I already did the "VS2005 express fix for windows apps", so I have the kernal32, ect... already included. I have no problem compiling 'non WxWidget' apps. But youre saying.. ANSI Debug: wxbase28d wxbase28d_net wxbase28d_odbc wxbase28d_xml wxexpatd wxjpegd wxmsw28d_adv wxmsw28d_aui wxmsw28d_core...
by Zeal
Mon Jun 04, 2007 6:57 am
Forum: Compiler / Linking / IDE Related
Topic: Unresolved External 'wxString' ONLY in debug mode
Replies: 20
Views: 3588

Dag nab it... Im not out of the woods yet. When I try to actually implement a test app, im getting more link errors. Im following the tutorial here... http://www.wxwidgets.org/wiki/index.php/Hello_World Here is my source... #include <windows.h> #include "wx/wxprec.h" #include "Main.h" IMPLEMENT_APP(...
by Zeal
Mon Jun 04, 2007 6:25 am
Forum: Compiler / Linking / IDE Related
Topic: Unresolved External 'wxString' ONLY in debug mode
Replies: 20
Views: 3588

http://www.wxwidgets.org/wiki/index.php ... _CPP_Guide

It was on the wiki, so I assumed it was 'legit'
by Zeal
Mon Jun 04, 2007 6:14 am
Forum: Compiler / Linking / IDE Related
Topic: Unresolved External 'wxString' ONLY in debug mode
Replies: 20
Views: 3588

I actually just selected Build->Batch Build, clicked Select All, then Build all (thats what the tut said to do). It took a long time (30+ minutes maybe more), but seemed to work (for release mode at least). When I 'rebuilt' the debug version just now, I did the same thing, but only selected the 'deb...
by Zeal
Mon Jun 04, 2007 5:48 am
Forum: Compiler / Linking / IDE Related
Topic: Unresolved External 'wxString' ONLY in debug mode
Replies: 20
Views: 3588

Ok, I rebuilt just the debug part, and that damn wxString link error is gone! Everything seems to be linking fine now in debug and release. Im getting some strange errors now with Ogre (my graphics rendering engine), but I guess WxWidgets is 'working' now...