Search found 48 matches

by scottfurry
Tue Sep 13, 2016 10:22 pm
Forum: Platform Related Issues
Topic: wxGTK executes fine wxMSW runs but poorly
Replies: 17
Views: 2471

Re: wxGTK executes fine wxMSW runs but poorly

I moved the wxColour definitions into places where they should be created during runtime.
Success!
Image

Lesson Learned
wxColour objects should not be treated as constants but defined at runtime.

Forward movement...
Thanks DoubleMax for the suggestion.
by scottfurry
Tue Sep 13, 2016 2:05 pm
Forum: Platform Related Issues
Topic: wxGTK executes fine wxMSW runs but poorly
Replies: 17
Views: 2471

Re: wxGTK executes fine wxMSW runs but poorly

Yeah for build! What colour is used depends on the tile values and number base. This is detail abstracted out (include tile type) to TileProperty class. (vexagonDefinitions.cpp -> line 147: SetBase() ). ColourMap is typedef'd as std::map<short, ColourPenBrush> ColourMap; where ColourPenBrush is a st...
by scottfurry
Tue Sep 13, 2016 7:48 am
Forum: Platform Related Issues
Topic: wxGTK executes fine wxMSW runs but poorly
Replies: 17
Views: 2471

Re: wxGTK executes fine wxMSW runs but poorly

Don't use wxWindowDC or wxClientDC. Drawing everything from inside the paint event handler is the cleanest and most reliable way. I found that both the hard way and through other posts here. Only the wxPaintDC is used in my code. The drawing sample recasts a wxPaintDC (derived from wxClientDC deriv...
by scottfurry
Tue Sep 13, 2016 7:41 am
Forum: Platform Related Issues
Topic: wxGTK executes fine wxMSW runs but poorly
Replies: 17
Views: 2471

Re: wxGTK executes fine wxMSW runs but poorly

IIRC, the drawing sample does a little slight of hand with wxWindowDC and wxGCDC. I think that's the reason I had the gdiplus header include as I was trying to have the gcc catch the need for the D2D render. I'll dig through the drawing sample again. More insight...hopefully. ...and not a bug. (plea...
by scottfurry
Tue Sep 13, 2016 7:33 am
Forum: Platform Related Issues
Topic: wxGTK executes fine wxMSW runs but poorly
Replies: 17
Views: 2471

Re: wxGTK executes fine wxMSW runs but poorly

I forgot about that myself.
Imagemagick, python, sed and awk are needed.
working on *sharing* generated copy of headers.
by scottfurry
Tue Sep 13, 2016 7:19 am
Forum: Platform Related Issues
Topic: wxGTK executes fine wxMSW runs but poorly
Replies: 17
Views: 2471

Re: wxGTK executes fine wxMSW runs but poorly

I thought I put a mention in the README that images were "generated". I'll double check that. The image files use a bash script (reading the conf file) in the graphics folder to generate headers and png's from SVG images. Appreciate the attempt... When I select "Use Graphics Context" in the sample, ...
by scottfurry
Tue Sep 13, 2016 6:52 am
Forum: Platform Related Issues
Topic: wxGTK executes fine wxMSW runs but poorly
Replies: 17
Views: 2471

Re: wxGTK executes fine wxMSW runs but poorly

There is a manifest file. I have windows 7 set for ( *EDIT ) "Windows Classic" theme. As for the DC... void GamePanel::OnPaint(wxPaintEvent &WXUNUSED(event)) { wxPaintDC pdc( this ); wxGraphicsContext *gc = wxGraphicsContext::Create( pdc ); if( gc ) { m_board_game->BoardDraw( gc ); if( !m_single_boa...
by scottfurry
Tue Sep 13, 2016 6:07 am
Forum: Platform Related Issues
Topic: wxGTK executes fine wxMSW runs but poorly
Replies: 17
Views: 2471

Re: wxGTK executes fine wxMSW runs but poorly

The source code is available on gitlab . Could I pair this down to a simple example to highlight the problems? Maybe... wxGraphicsContext Under wxGTK - the game screen should look as follows: http://i.imgur.com/c6yOgtY.png This is what I see under Windows 7: http://i.imgur.com/mzMSENh.png Starting a...
by scottfurry
Tue Sep 13, 2016 2:14 am
Forum: Platform Related Issues
Topic: wxGTK executes fine wxMSW runs but poorly
Replies: 17
Views: 2471

Re: wxGTK executes fine wxMSW runs but poorly

I should note...
I've re-built wxWidgets latest with --enable-graphics_ctx, which I believe should define wxUSE_GRAPHIC_CONTEXT.
Still no change in desired output.
by scottfurry
Tue Sep 13, 2016 2:11 am
Forum: Platform Related Issues
Topic: wxGTK executes fine wxMSW runs but poorly
Replies: 17
Views: 2471

wxGTK executes fine wxMSW runs but poorly

I have an application called vexagon . It is almost feature complete but I have run into cross-platform issues. I'm building against Arch supplied package for wxWidgets 3.0.2 (both wxGTK2 and x86_64-w64-mingw32). I'm also building against wxWidgets git-latest (local build - wxGTK and wxMSW). Using w...
by scottfurry
Wed Dec 02, 2015 9:55 pm
Forum: wxCode
Topic: Trying to use wxEMail to delete message(s)
Replies: 21
Views: 5909

Re: Trying to use wxEMail to delete message(s)

From the manual and the source code I see no support for MSVC - my preferred environment. Some very few and dated comments in the forum do refer to MSVC, but only to earlier versions. My current environment is MSVC 2010 Express, though I could likely run a more recent version, if necessary, which I...
by scottfurry
Tue Dec 01, 2015 12:31 am
Forum: wxCode
Topic: Trying to use wxEMail to delete message(s)
Replies: 21
Views: 5909

Re: Trying to use wxEMail to delete message(s)

FYI,
I have been able to use this library to access google (IMAP).
It can be a little quirky to understand and the documentation (also a downloadable PDF) is not totally clear, but it works quite well.

PM if your interested examples.
by scottfurry
Mon Nov 30, 2015 6:55 pm
Forum: wxCode
Topic: Trying to use wxEMail to delete message(s)
Replies: 21
Views: 5909

Re: Trying to use wxEMail to delete message(s)

VMime would be my first suggestion. http://www.vmime.org/ From the About page VMime is a powerful C++ class library for working with RFC-822 and MIME messages and Internet messaging services like IMAP, POP or SMTP. With VMime you can parse, generate and modify messages, and also connect to store and...
by scottfurry
Wed Oct 21, 2015 9:10 pm
Forum: Platform Related Issues
Topic: wxHyperLinkCtrl double event response
Replies: 4
Views: 1010

Re: wxHyperLinkCtrl double event response

I had looked through the wxWidgets Trac for errors. I guess my search was not thorough enough. It also explains why when I clicked on 3.1.x locally built samples the problem didn't occur. I would encourage the dev's to backport the resolution to the 3.0 branch, if possible. doublemax - most apprecia...