Search found 10 matches

by DFYX
Wed Jul 02, 2008 8:15 pm
Forum: C++ Development
Topic: Weird segfault when having lots of controls in a frame
Replies: 2
Views: 483

I did, but I didn't get any solution because the debugger acts a little weird. "Run to cursor" is the only thing that actually works. For everything else, nothing happens. I'm quite sure it has worked before, but at the moment, I can't get it working for any project. Edit: found my problem. I didn't...
by DFYX
Wed Jul 02, 2008 7:37 pm
Forum: C++ Development
Topic: Weird segfault when having lots of controls in a frame
Replies: 2
Views: 483

Weird segfault when having lots of controls in a frame

I'm getting a quite weird problem. I have a wxPropertyGrid with around 30 properties, some wxPanels, some wxButtons etc. in my app, which means I probably have tons of controls. As soon as I reach a certain number of controls in my frame, the app segfaults somewhere in the frame's constructor. If I ...
by DFYX
Mon May 21, 2007 10:27 am
Forum: Platform Related Issues
Topic: Linux: socket sends only one byte
Replies: 4
Views: 1308

Phew... thanks for your answers. Didn't have any time in the last few days so I couldn't answer. @lowjoel: Well, I guess you're right. I found some similar code somewhere else and just changed a few things. I didn't think much about casts, since it worked on my windows machine. So if this is the rea...
by DFYX
Mon May 07, 2007 9:35 am
Forum: Platform Related Issues
Topic: Linux: socket sends only one byte
Replies: 4
Views: 1308

If the link doesn't work, try http://wxirc.svn.sourceforge.net/svnroot/wxirc/trunk/ Sourceforge can be quite strange :wink:

Your tip sounds quite good, but using wxSOCKET_WAITALL in the constructor didn't help.
by DFYX
Sun May 06, 2007 6:37 pm
Forum: Platform Related Issues
Topic: Linux: socket sends only one byte
Replies: 4
Views: 1308

Linux: socket sends only one byte

I've written a small IRC Client with wxWidgets. It runs fine on Windows XP and there were no problems on Linux in the past, but when I tried if the latest version runs on Linux, something strange happened. For every Write() only one byte is sent. At least that's what Wireshark tells me. I use the fo...
by DFYX
Sat Apr 14, 2007 8:13 pm
Forum: Platform Related Issues
Topic: Gentoo: set-wxconfig
Replies: 4
Views: 804

I did uninstall 2.6, so that's not the problem.

I'm not sure what 'set-wxconfig' is, but it looks like some gentoo-specific method to find the correct version of wxWidgets. Unfortunately I don't know where it gets its information from.
by DFYX
Sat Apr 14, 2007 8:03 pm
Forum: Platform Related Issues
Topic: Gentoo: set-wxconfig
Replies: 4
Views: 804

VLC? Are you using prebuilt binaries?
No, on Gentoo you usually install everything from the source files.
to check whether it is installed correctly, open a terminal and type 'wx-config --version'
Everything is fine there. It shows 2.8.3

So it's probably Gentoo's fault.
by DFYX
Sat Apr 14, 2007 7:40 pm
Forum: Platform Related Issues
Topic: Gentoo: set-wxconfig
Replies: 4
Views: 804

Gentoo: set-wxconfig

Since it seems as if some files are missing in the wxGTK version which is in portage (2.6.3.3), I downloaded the sources of 2.8, compiled it myself and added "x11-libs/wxGTK-2.8.3" to /etc/portage/profile/package.provided. But when I emerged vlc, I got an error message: !!! set-wxconfig: Error: Can'...
by DFYX
Wed Apr 04, 2007 11:29 am
Forum: C++ Development
Topic: Bring to foreground
Replies: 10
Views: 1831

I guess that could work. I'll edit this post as soon as I've tried.

Edit:
Works great. Thanks!
by DFYX
Wed Apr 04, 2007 10:50 am
Forum: C++ Development
Topic: Bring to foreground
Replies: 10
Views: 1831

I'm sorry for posting in a thread which is more than one year old, but I guess that's better than opening a new one since I have exactly the same problem. I made a wxTreeCtrl with a list of files and there are two ways for the user to open a preview window. He can either doble click on the node in t...