Search found 29 matches

by DanRR
Wed Mar 16, 2016 4:32 am
Forum: C++ Development
Topic: Reuse or recreate dialog for best preformence?
Replies: 2
Views: 478

Reuse or recreate dialog for best preformence?

Which is better, creating a frequently used dialog, every time its needed, of reusing if, for getting the best speed? will reusing a simple dialog, with a few text boxes, buttons, etc. will spend a lot of memory?
Thanks
by DanRR
Wed Jul 08, 2015 7:06 am
Forum: C++ Development
Topic: Seting wxListCtrl column font fails
Replies: 4
Views: 750

Re: Seting wxListCtrl column font fails

Thanks again doublemax, I need a virtual storage and I'm not sure how to implement it with wxDataViewCtrl or wxDataViewListCtrl. I'll look into it it when I'll have more time and maybe check also wxGrid. For the current prototype stage of my project, I'll settle for the wxListCtrl::SetFont and try t...
by DanRR
Tue Jul 07, 2015 9:56 am
Forum: C++ Development
Topic: Seting wxListCtrl column font fails
Replies: 4
Views: 750

Re: Seting wxListCtrl column font fails

Thanks doublemax!
Is it possible to SetFont globally and then set the column heads fonts in order to avoid OnGetItemColumnAttr bypass and get it working under GTK?
by DanRR
Tue Jul 07, 2015 9:16 am
Forum: C++ Development
Topic: Seting wxListCtrl column font fails
Replies: 4
Views: 750

Seting wxListCtrl column font fails

Hi, I'm using Windows XP wx3.0.2. I want to set the font for all wxListCtrl columns font, except their heads. The following code doesn’t sets the fonts. Please help me fix it. Thanks. can_view_ctrl::can_view_ctrl(wxWindow *parent) : wxListCtrl(parent, wxID_ANY, wxDefaultPosition, wxDefaultSize, wxLC...
by DanRR
Mon Jan 26, 2015 12:58 pm
Forum: Platform Related Issues
Topic: WxWidgets 3.0.2 apps hangs at start with high CPU load
Replies: 9
Views: 1565

Re: WxWidgets 3.0.2 apps hangs at start with high CPU load

Thanks doublemax,
I built it as static lib and it works fine, no delay at all.
I can manage with static build in my current project, so I'll compromise for now.
by DanRR
Fri Jan 23, 2015 5:34 pm
Forum: Platform Related Issues
Topic: WxWidgets 3.0.2 apps hangs at start with high CPU load
Replies: 9
Views: 1565

Re: WxWidgets 3.0.2 apps hangs at start with high CPU load

How long was the delay you've seen?
I didn't tried the those tips, I used the following build command line:

Code: Select all

mingw32-make -f makefile.gcc CXXFLAGS="-std=gnu++11" SHARED=1 UNICODE=1 BUILD=release
I Think this answer to the third tip. I'll try to test is and post the results.
by DanRR
Thu Jan 22, 2015 10:33 pm
Forum: Platform Related Issues
Topic: WxWidgets 3.0.2 apps hangs at start with high CPU load
Replies: 9
Views: 1565

Re: WxWidgets 3.0.2 apps hangs at start with high CPU load

Sure, that's the minimal sample that was compiled using its makefile:
https://www.dropbox.com/s/ob0baawefmq7p ... al.7z?dl=0
Thanks!
by DanRR
Thu Jan 22, 2015 7:52 pm
Forum: Platform Related Issues
Topic: WxWidgets 3.0.2 apps hangs at start with high CPU load
Replies: 9
Views: 1565

Re: WxWidgets 3.0.2 apps hangs at start with high CPU load

Thanks PB and doublemax, Here are some answers and related facts: I compiled the minimal sample with the makefile, as you suggested, and it has the same delay problem. I compiled the original test project with WX 2.8.12 and there was no problem! I compiled the the project using precompiled WX 3.0.2 ...
by DanRR
Thu Jan 22, 2015 8:48 am
Forum: Platform Related Issues
Topic: WxWidgets 3.0.2 apps hangs at start with high CPU load
Replies: 9
Views: 1565

WxWidgets 3.0.2 apps hangs at start with high CPU load

Applications that compiled with WxWidgets 3.0.2 hangs about 20 seconds at stat before become visual, with 100% CPU load. This happens on any application I've tested, including the default Code Blocks WX application template. I've tested it, on Windows XP and Windows 7 (32). I've compiled the applica...
by DanRR
Sat Feb 07, 2009 8:35 pm
Forum: General Forum Issues
Topic: How about wxPython forum?
Replies: 5
Views: 3747

How about wxPython forum?

There is wxPython mailing list, but I think that a web forum is much better media for community support.
It looks to me that this forum is the perfect place for it, since it deals with all other wxWidgets stuff.
What is your opinion?
by DanRR
Sun Oct 05, 2008 5:43 pm
Forum: C++ Development
Topic: wxDateTime::GetMillisecond always returns zero
Replies: 2
Views: 728

Thanks doublemax!
wxDateTime::UNow do it.
by DanRR
Sun Oct 05, 2008 5:24 pm
Forum: C++ Development
Topic: wxDateTime::GetMillisecond always returns zero
Replies: 2
Views: 728

wxDateTime::GetMillisecond always returns zero

I've used wxDateTime::GetMillisecond int he following code: wxString ws_log; if(Timestamp) { wxDateTime time = wxDateTime::Now(); ws_log = time.FormatTime(); int msec = time.GetMillisecond(); ws_log << wxT(".") << msec << wxT(" "); } // ... The GetMillisecond function always returns zero. Did I miss...
by DanRR
Thu Oct 02, 2008 12:28 pm
Forum: C++ Development
Topic: How can I change wxFrame position dynamically?
Replies: 2
Views: 698

by DanRR
Thu Oct 02, 2008 10:27 am
Forum: C++ Development
Topic: How can I change wxFrame position dynamically?
Replies: 2
Views: 698

How can I change wxFrame position dynamically?

Hello,
I want to change wxFrame position, after it's creation, how do I do that?

Thanks