Search found 72 matches

by bcteh
Tue May 24, 2016 4:26 pm
Forum: Compiler / Linking / IDE Related
Topic: Window 10 64bit problem
Replies: 9
Views: 1552

Re: Window 10 64bit problem

Opp .. ](*,) ..
After disable "Avast anti free antivirus" ..
Problem solve..
Two night, just build and test :shock:
by bcteh
Tue May 24, 2016 3:54 pm
Forum: Compiler / Linking / IDE Related
Topic: Window 10 64bit problem
Replies: 9
Views: 1552

Re: Window 10 64bit problem

Thank for advice.
Try to clean out everything and rebuild for IDE without change anything.
See how ...
by bcteh
Tue May 24, 2016 3:25 pm
Forum: Compiler / Linking / IDE Related
Topic: Window 10 64bit problem
Replies: 9
Views: 1552

Re: Window 10 64bit problem

I test for both,from command line and visual studio.
Build 64 or 32 bit also go to loop. #-o
No error during build.
by bcteh
Tue May 24, 2016 5:29 am
Forum: Compiler / Linking / IDE Related
Topic: Window 10 64bit problem
Replies: 9
Views: 1552

Re: Window 10 64bit problem

yes, all 3 version , go into loop. No modify anything, just download compile and test the sample. Something i did at window7 32bit, without any problem. No sure, is this 64/32bit binary, Tonight will check it again I just open the sample with visio studio 2010 and Change the property C++ Code genene...
by bcteh
Mon May 23, 2016 4:47 pm
Forum: Compiler / Linking / IDE Related
Topic: Window 10 64bit problem
Replies: 9
Views: 1552

Window 10 64bit problem

Hi, I use the below command to build wxwidget 2.94 / 3.02 / 3.10 nmake -f makefile.vc BUILD=debug UNICODE=1 SHARE=0 RUNTIME_LIBS=static and test for minimal sample. There sample run successfully on window 7. But on window 10 (64bit) the forever hang there ( no screen show). Try put breakpoint on fir...
by bcteh
Fri Apr 05, 2013 9:47 am
Forum: Platform Related Issues
Topic: xCode 4.6 - wxWidgets 2.9.4 cannot "configure&make"!?!
Replies: 2
Views: 1931

Re: xCode 4.6 - wxWidgets 2.9.4 cannot "configure&make"!?!

You didn't install c/c++ compiler.

Open XCode go to preferences under downloads install command line tools
by bcteh
Sat Dec 29, 2012 5:30 pm
Forum: Platform Related Issues
Topic: Problems with wxDragImage on Mac
Replies: 1
Views: 1235

Re: Problems with wxDragImage on Mac

Same on osx 10.8.2 .
2.9.5 coming soon . hopefully more stable
by bcteh
Fri Dec 28, 2012 1:48 pm
Forum: Platform Related Issues
Topic: Problem stc sample on cocoa
Replies: 0
Views: 808

Problem stc sample on cocoa

Hi, My application use around 7%~10%++ of CPU resources when the program is at idle. After checking for a day :evil: , i suspect it cause by wxStyleTextctrl . I run the stc sample program. It aslo use 0.6%~0.7% CPU resources. Does anyone notice this problem ? how to solve it ? partial solve: http://...
by bcteh
Wed Dec 26, 2012 3:39 am
Forum: C++ Development
Topic: wxEVT_UPDATE_UI on wxWidgets 2.9.4
Replies: 2
Views: 1085

Re: wxEVT_UPDATE_UI on wxWidgets 2.9.4

ha ha. that is my mistake. The toolbar didn't refesh after enabled/disabled. I addd in a refresh statement. That cause it using a lot resources. funcToolBar->EnableTool(ID, false); funcToolBar->Refresh(); --> that is the problem opps.. I make a mistake for few years .. :oops: I should using event->E...
by bcteh
Tue Dec 25, 2012 4:35 pm
Forum: C++ Development
Topic: wxEVT_UPDATE_UI on wxWidgets 2.9.4
Replies: 2
Views: 1085

wxEVT_UPDATE_UI on wxWidgets 2.9.4

Hi Is wxEVT_UPDATE_UI still supported for wxWidgets 2.9 ? I use it to control the menu/toolbar enable or disable state. For wxWidgets 2.8 release, it didn't use much of resources. But for wxWidgets 2.9, my application use about 50% cpu resources and event worst for OSX, It took around 80++ cpu resou...
by bcteh
Sun Dec 23, 2012 11:44 am
Forum: Platform Related Issues
Topic: wxNativePixelData assert on cocoa
Replies: 3
Views: 1641

Re: wxNativePixelData assert on cocoa

Thank for advices. I check on wxwidgets source, only found m_rawAccessCount variable on osx/core/bitmaps.cpp It assign m_rawAccessCount = 0 on Init(); Increase on BeginRawAccess() and decrease on EndRawAccess() When declare wxNativePixelData xxx(bmp); the flow go to BeginRowAccess. May be that is a ...
by bcteh
Wed Dec 19, 2012 2:47 pm
Forum: Platform Related Issues
Topic: wxNativePixelData assert on cocoa
Replies: 3
Views: 1641

wxNativePixelData assert on cocoa

Hi, For wx 2.94, when used wxNativePixelData data(bmp); It cause below assert error, It is safe to comment out this assert message at ../../src/osx/core/bitmap.cpp(380) ? I didn't saw any difference at my application, if i just ignore this message. ../../src/osx/core/bitmap.cpp(380): assert "m_rawAc...
by bcteh
Mon Dec 17, 2012 5:47 am
Forum: Platform Related Issues
Topic: Drag and drop is not working on mac
Replies: 5
Views: 3538

Re: Drag and drop is not working on mac

Found this issue http://trac.wxwidgets.org/changeset/72108
After apply the patch the bug fix. =D>
by bcteh
Mon Dec 17, 2012 4:49 am
Forum: Platform Related Issues
Topic: Package Creation tutorial out an application for Ubunt
Replies: 1
Views: 935

Re: Package Creation tutorial out an application for Ubunt

I follow this http://tldp.org/HOWTO/html_single/Debian-Binary-Package-Building-HOWTO/ and First, have a look at the contents of .deb packages similar to your software. To get the .deb file, use apt-get install --reinstall ${PACKAGENAME}, abort the process once all files are downloaded, and fetch the...
by bcteh
Sun Dec 16, 2012 4:59 pm
Forum: Platform Related Issues
Topic: Drag and drop is not working on mac
Replies: 5
Views: 3538

Re: Drag and drop is not working on mac

Any new about this ?
I can't find the issue in mailing list and trac.wxwidgets.org .