Search found 10 matches

by rssmps
Thu Jun 29, 2006 5:38 pm
Forum: Compiler / Linking / IDE Related
Topic: FAQ for IDE related issues v2
Replies: 19
Views: 36178

One tip on running the samples. I found that the the sample solutions willl compile certain lib files depending on what is attached.

So the impact is that if you built the library first and then ran the samples, your orig lib settings will be overwritten with the settings in the sample.
by rssmps
Thu Jun 29, 2006 4:29 pm
Forum: Compiler / Linking / IDE Related
Topic: include / lib path confusion
Replies: 1
Views: 705

Re: include / lib path confusion

Ok, I figured it out.... here's the commad line for c/c++ in proj settings: /Od /I "C:\Program Files\Microsoft Visual Studio 8\VC\PlatformSDK\Include" /I "C:\Program Files\Microsoft Visual Studio 8\VC\include" /I "C:\wxWidgets-2.6.3\lib\vc_lib\mswd" /I "C:\wxWidgets-2.6.3\include" /D "WIN32" /D "__W...
by rssmps
Tue Jun 27, 2006 4:06 pm
Forum: Compiler / Linking / IDE Related
Topic: Problem with building wxWidgets 2.6.3 with VC++ 2005
Replies: 1
Views: 516

Re: Problem with building wxWidgets 2.6.3 with VC++ 2005

do you have to compile as dll?

have you tried if LIB works?
by rssmps
Tue Jun 27, 2006 12:53 am
Forum: Compiler / Linking / IDE Related
Topic: include / lib path confusion
Replies: 1
Views: 705

include / lib path confusion

I normally try searching for answers first in the forum before I ask but this time, the search has gotten me so confused I'm getting no where. I first started using the direction in the FAQ for VS2003. In that case, I was using the wxWindows.dsw. I was able to compile and run the sample tutorial htt...
by rssmps
Mon Jun 26, 2006 9:58 pm
Forum: Compiler / Linking / IDE Related
Topic: FAQ for IDE related issues v2
Replies: 19
Views: 36178

Should this be part of the FAQ?

src\wxWindows.dsw vs. build\msw\wx.dsw
http://forums.wxwidgets.org/viewtopic.p ... indows+dsw
by rssmps
Sun Jun 25, 2006 8:43 am
Forum: Compiler / Linking / IDE Related
Topic: Empty project / W32 console project differences
Replies: 4
Views: 999

OK, I put wxT around " " and those errors went away. However, the following errors are now popping up. all this is due to difference between empty project and console project settings? ------ Build started: Project: hworld, Configuration: Debug Win32 ------ Compiling... hworld.cpp Compiling manifest...
by rssmps
Sat Jun 24, 2006 10:09 am
Forum: Compiler / Linking / IDE Related
Topic: Empty project / W32 console project differences
Replies: 4
Views: 999

http://wxwidgets.org/docs/tutorials/hworld.txt so from: MyFrame *frame = new MyFrame( "Hello World", wxPoint(50,50), wxSize(450,340) ); to this? MyFrame *frame = new MyFrame( wxT("Hello World"), wxPoint(50,50), wxSize(450,340) ); Why wasen't this needed in the original empty project? still confused....
by rssmps
Sat Jun 24, 2006 9:39 am
Forum: Compiler / Linking / IDE Related
Topic: Can't debug in VS Express Edition
Replies: 5
Views: 1383

Unfortunately, the settings mentioned above do not work for me. Even with the changes, I still get exactly the same error.

I setup my test project with the steps described by Jorg in the sticky.
I'll have to try the samples and see if debuggin works there or not.

Thanks!
by rssmps
Sat Jun 24, 2006 9:31 am
Forum: Compiler / Linking / IDE Related
Topic: Empty project / W32 console project differences
Replies: 4
Views: 999

Empty project / W32 console project differences

I followed Jorg's sample program running steps as listed in the FAQ sticky. The program compiled and ran without any major issues. In my program, I want to be able to send text to a console in addition to the GUI. So, I thought I would use the console project. Going through the same steps, I end up ...
by rssmps
Sat Jun 24, 2006 8:25 am
Forum: Compiler / Linking / IDE Related
Topic: FAQ for IDE related issues v2
Replies: 19
Views: 36178

unresolved external symbol _main

LIBCMTD.lib(crt0.obj) : error LNK2019: unresolved external symbol _main referenced in function ___tmainCRTStartup


if you get this and you're app is using/building GUI, it's likly you're using console rather than window.

project|properties|Linker||System|SubSystem: change console to windows.