Search found 15 matches

by rareman
Tue Jan 21, 2020 10:02 am
Forum: Compiler / Linking / IDE Related
Topic: build wxWidgets 3.1.1 64-bit on UNIX
Replies: 9
Views: 855

Re: build wxWidgets 3.1.1 64-bit on UNIX

Hi,

I'm done build 64 bit for gtk my build here below.

$ ../configure CFLAGS=-m64 CXXFLAGS=-m64 LDFLAGS=-m64 --with-gtk --disable-threads --enable-utf8 --enable-utf8only --enable-permissive

Thanks
by rareman
Tue Jan 21, 2020 8:58 am
Forum: Compiler / Linking / IDE Related
Topic: build wxWidgets 3.1.1 64-bit on UNIX
Replies: 9
Views: 855

Re: build wxWidgets 3.1.1 64-bit on UNIX

Hi, I still have some problem for 64 bit for build gtk failed here below. /export/home/******/WX/wxWidgets-3.0.4/build_gtk/bk-deps g++ -c -o netdll_sckaddr.o -I./.pch/wxprec_netdll -D__WXGTK__ -DWXBUILDING -I../src/regex -DwxUSE_GUI=0 -DWXUSINGDLL -DWXMAKINGDLL_NET -fPIC -DPIC -Wall -Wundef -Wunused...
by rareman
Mon Jan 20, 2020 9:02 am
Forum: Compiler / Linking / IDE Related
Topic: build wxWidgets 3.1.1 64-bit on UNIX
Replies: 9
Views: 855

Re: build wxWidgets 3.1.1 64-bit on UNIX

Hi, OS: solaris 11.3(sparc) wx version: 3.0.4 gcc version: 4.5 result: build success output : 64 bit application ./configure CC=${IDE_CC} CXX=${IDE_CXX} CFLAGS="-m64" CXXFLAGS="-m64" LDFLAGS="-m64 -L/usr/bin/64" --with-opengl --with-opengl --enable-utf8 --enable-stc --enable-compat28 --prefix=/usr/l...
by rareman
Fri Jan 17, 2020 7:56 am
Forum: Compiler / Linking / IDE Related
Topic: build wxWidgets 3.1.1 64-bit on UNIX
Replies: 9
Views: 855

Re: build wxWidgets 3.1.1 64-bit on UNIX

Hi it will report it as 32-bit? -Yep. By command file Also, did you see this? -Nope, I'll read that Also below my build what i found 1. OS: solaris 11.3(sparc) wx version: 3.1.1 gcc version: 4.5 result: build success output : 32 bit application 2. OS: solaris 11.3(sparc) wx version: 3.1.1 gcc versio...
by rareman
Fri Jan 17, 2020 2:11 am
Forum: Compiler / Linking / IDE Related
Topic: build wxWidgets 3.1.1 64-bit on UNIX
Replies: 9
Views: 855

Re: build wxWidgets 3.1.1 64-bit on UNIX

Hi ONEEYEMAN ,

No error build was successful but still got 32 bit. I tried to put parameter CFLAGS="-O2 -m64" CXXFLAGS=-fPIC LDFLAGS=-m64 output not different.

Thanks
by rareman
Thu Jan 16, 2020 2:01 pm
Forum: Compiler / Linking / IDE Related
Topic: build wxWidgets 3.1.1 64-bit on UNIX
Replies: 9
Views: 855

Re: build wxWidgets 3.1.1 64-bit on UNIX

Hi David,

This post for wxWidgets for 64 bit cause after build (default) its was 32 bit then I tried many option but not success also didn't see option in configure.

Thanks.
by rareman
Thu Jan 16, 2020 10:09 am
Forum: Compiler / Linking / IDE Related
Topic: build wxWidgets 3.1.1 64-bit on UNIX
Replies: 9
Views: 855

build wxWidgets 3.1.1 64-bit on UNIX

Hi, How to build wxWidgets 3.1.1 64-bit on UNIX (solaris/sparc)? I didn't see option in configure here my build OS: solaris 11.3(sparc) wx version: 3.1.1 gcc version: 4.5 ../configure CFLAGS="-O2 -m64" CXXFLAGS=-fPIC LDFLAGS=-m64 --with-gtk --with-opengl --enable-stc --enable-compat28 --prefix=/usr/...
by rareman
Mon Dec 23, 2019 8:17 am
Forum: Compiler / Linking / IDE Related
Topic: Solaris(sparc)11.3 Build Failure wxWidgets 3.1.3
Replies: 15
Views: 1307

Re: Solaris(sparc)11.3 Build Failure wxWidgets 3.1.3

Hi,

thank you all for your support.
by rareman
Mon Dec 23, 2019 8:08 am
Forum: Compiler / Linking / IDE Related
Topic: Solaris(sparc)11.3 Build Failure wxWidgets 3.1.3
Replies: 15
Views: 1307

Re: Solaris(sparc)11.3 Build Failure wxWidgets 3.1.3

stahta01 wrote:
Mon Dec 23, 2019 7:02 am
https://trac.wxwidgets.org/ticket/18368

Might want to try downgrading GCC if that can be done.

Tim S.
This is good one and result is successes just downgrade gcc from 4.8.2 to 4.5.2.

Output:
BUILD SUCCESSFUL (total time: 28m 3s)

Many Thanks :)
by rareman
Mon Dec 23, 2019 3:11 am
Forum: Compiler / Linking / IDE Related
Topic: Solaris(sparc)11.3 Build Failure wxWidgets 3.1.3
Replies: 15
Views: 1307

Re: Solaris(sparc)11.3 Build Failure wxWidgets 3.1.3

Hi, Here last build pre-build :~/WX/wxWidgets-3.1.3$ ./configure --with-gtk --enable-compat28 --disable-xlocale config.log :~/WX/wxWidgets-3.1.3$ grep xlocal config.log $ ./configure --with-gtk --enable-compat28 --disable-xlocale wx_cv_use_xlocale=wxUSE_XLOCALE=no build output in file attached. my g...
by rareman
Fri Dec 20, 2019 3:31 am
Forum: Compiler / Linking / IDE Related
Topic: Solaris(sparc)11.3 Build Failure wxWidgets 3.1.3
Replies: 15
Views: 1307

Re: Solaris(sparc)11.3 Build Failure wxWidgets 3.1.3

Hi,

My attached config.log if maybe getting idea from config.log


Thanks
by rareman
Thu Dec 19, 2019 2:52 am
Forum: Compiler / Linking / IDE Related
Topic: Solaris(sparc)11.3 Build Failure wxWidgets 3.1.3
Replies: 15
Views: 1307

Re: Solaris(sparc)11.3 Build Failure wxWidgets 3.1.3

Hi

As you said build wxWidgets 3.xx on Solaris 11.4 successful I guess cause of solaris 11.4 have package wxwidgets 3.0xx Or could you help run command check package wx with #pkg list -af | grep -i wxwidgets

Thanks
by rareman
Tue Dec 17, 2019 3:05 am
Forum: Compiler / Linking / IDE Related
Topic: Solaris(sparc)11.3 Build Failure wxWidgets 3.1.3
Replies: 15
Views: 1307

Re: Solaris(sparc)11.3 Build Failure wxWidgets 3.1.3

Hi,

Oh Thanks but can't upgrade OS that way painful for application migration/upgrade :)
by rareman
Mon Dec 16, 2019 7:56 am
Forum: Compiler / Linking / IDE Related
Topic: Solaris(sparc)11.3 Build Failure wxWidgets 3.1.3
Replies: 15
Views: 1307

Re: Solaris(sparc)11.3 Build Failure wxWidgets 3.1.3

Hi Here build with wxWidgets-3.1.1 with ./configure --enable-debug --with-gtk still failed here below(see wxWidgets-3.1.1). Another i didn't get "Ok. The Solaris problem really was that wcsdup and few others are not declared in default C++ name space. So std::wcsdup will solve the issue for now." fr...
by rareman
Fri Dec 13, 2019 7:28 am
Forum: Compiler / Linking / IDE Related
Topic: Solaris(sparc)11.3 Build Failure wxWidgets 3.1.3
Replies: 15
Views: 1307

Solaris(sparc)11.3 Build Failure wxWidgets 3.1.3

-INFO OS: Solaris 11.3 SRU36 wxWidgets: 3.1.3 (Source) GCC version: 4.8.2, 5.4.0 and Sun Studio 12.6 wx-config version: 2.8.12 ./configure (simple) and or --with-gtk or --with-x11 Status: failed - I am trying to build wxWidgets 3.1.3 on Solaris 11.3 SRU36.10 with both gcc 4.8.2 and sun studio 12.6 a...