Search found 5 matches

by drdrbergman
Mon Nov 04, 2019 3:34 pm
Forum: Compiler / Linking / IDE Related
Topic: x64 - vs2015 - __w64 can only be specified on int, long and pointer types
Replies: 8
Views: 626

Re: x64 - vs2015 - __w64 can only be specified on int, long and pointer types

All, I have a similar issue but not with the widgets examples. Those run fine. But the wxPLplotDemo that comes with plplot is compiling and says 1 succeeded, 0 failed and produces the exe. However, there _w64 error shows up in the error list and the exe will not run. I built and installed widgets an...
by drdrbergman
Wed Oct 30, 2019 4:31 pm
Forum: Compiler / Linking / IDE Related
Topic: Fatal Runtime Error: Mismatch between the program and library build versions detected.
Replies: 9
Views: 1301

Re: Fatal Runtime Error: Mismatch between the program and library build versions detected.

For widgets I use the VS sln that comes with it. Plplot build uses cmake then the install uses a VS sln. I did catch a discrepancy between the SDK setting that was default setting in each a while back but that is fixed. The example is from the plplot distribution but I did not build it with the rest...
by drdrbergman
Tue Oct 29, 2019 11:27 pm
Forum: Compiler / Linking / IDE Related
Topic: Fatal Runtime Error: Mismatch between the program and library build versions detected.
Replies: 9
Views: 1301

Re: Fatal Runtime Error: Mismatch between the program and library build versions detected.

What could be different if all things that I can control (or at least know about) are the same?
The SDK and compiler versions were identical. Is there some other setting that I could check, say preprocessor settings?
Any help would be appreciated.
by drdrbergman
Tue Oct 29, 2019 5:50 pm
Forum: Compiler / Linking / IDE Related
Topic: Fatal Runtime Error: Mismatch between the program and library build versions detected.
Replies: 9
Views: 1301

Re: Fatal Runtime Error: Mismatch between the program and library build versions detected.

Thank you Tim. I suspected as much after reading a few stackoverflow and other blog posts. However, I just purged everything and did a clean rebuild of widgets and plplot this time making sure that the same SDk and compiler choice was made in all projects. I did have 2 SDK's and it seems that widget...
by drdrbergman
Mon Oct 28, 2019 6:33 pm
Forum: Compiler / Linking / IDE Related
Topic: Fatal Runtime Error: Mismatch between the program and library build versions detected.
Replies: 9
Views: 1301

Re: Fatal Runtime Error: Mismatch between the program and library build versions detected.

I just had the same issue arise while trying to run the wxplplot example in plplot. I built the widgets and plplot libs/dlls with the exact same compiler as the example and there are no other widgets distributions on my computer. Could there be another cause and solution?