Search found 6 matches

by DoctorDavid
Wed Nov 30, 2016 8:45 pm
Forum: General Development
Topic: Request administrator level on Windows [Lua]
Replies: 1
Views: 687

Request administrator level on Windows [Lua]

So I've got yet another question, this time I'm trying to get administrator level via a Lua application. I couldn't find anything online, have you got any ideas?
by DoctorDavid
Wed Nov 23, 2016 5:10 pm
Forum: General Development
Topic: io.open() not working (returning nil) [Lua]
Replies: 8
Views: 4288

Re: io.open() not working (returning nil) [Lua]

Well, I didn't know of that feature... It's handy! :lol: "No such file or directory" And then I realized: I didn't have those folders set up. So what I'm going to do is make an "installer" kinda thing that creates those things automatically. In order to open those things, you need to have these fold...
by DoctorDavid
Tue Nov 22, 2016 7:59 pm
Forum: General Development
Topic: io.open() not working (returning nil) [Lua]
Replies: 8
Views: 4288

Re: io.open() not working (returning nil) [Lua]

Exactly the same error message. Hardcoded and relative paths apparently aren't the problem. :cry:
by DoctorDavid
Tue Nov 22, 2016 2:26 pm
Forum: General Development
Topic: io.open() not working (returning nil) [Lua]
Replies: 8
Views: 4288

Re: io.open() not working (returning nil) [Lua]

That's actually a good point, although I'm in my Desktop Programming folder (with quite a large dir tree in that said folder) C:\Users\David\Desktop\Programmieren\Lua\wxLua\bin\wxLuaEdit.exe <- That is the path to the wxLuaEdit.exe (Like I said, desktop, so I should have writing permissions) and at ...
by DoctorDavid
Mon Nov 21, 2016 8:00 pm
Forum: General Development
Topic: io.open() not working (returning nil) [Lua]
Replies: 8
Views: 4288

Re: io.open() not working (returning nil) [Lua]

Oops, I forgot something! :lol: I'm running on Windows 8.1, wxLua 2.8.12.3 and Lua 5.2!
by DoctorDavid
Mon Nov 21, 2016 7:31 pm
Forum: General Development
Topic: io.open() not working (returning nil) [Lua]
Replies: 8
Views: 4288

io.open() not working (returning nil) [Lua]

Hello, guys! I'm currently programming an IRC client in Lua using the wxLua library. At the moment I'm working on the server and user saving. And that's where the problem is: My IO writing doesn't work. On my understanding, it can't open the file (which it only will if the file isn't existing, hence...