Search found 5 matches

by Warepire
Mon Feb 03, 2014 2:39 pm
Forum: Compiler / Linking / IDE Related
Topic: Cannot build with "system" jpeg lib
Replies: 9
Views: 3770

Re: Cannot build with "system" jpeg lib

That works. I was hoping to do it without editing the setup.h file but I guess that isn't possible in this case. I think this should be added to the codebase so that this functionality becomes available for all who build on Windows using VS so that it becomes as easy to use external libs for this ca...
by Warepire
Mon Jan 20, 2014 1:21 pm
Forum: Compiler / Linking / IDE Related
Topic: Cannot build with "system" jpeg lib
Replies: 9
Views: 3770

Re: Cannot build with "system" jpeg lib

After spending the weekend digging some more, I found the file responsible for defining the use of wxjpegd.lib over my newer jpeg.lib. It's defined in the setup-wrapper for Vistual Studio compilers. More specifically, these 3 lines of code in "wxWidgets-3.0.0/include/msvc/wx/setup.h": #if wxUSE_LIBJ...
by Warepire
Fri Jan 10, 2014 6:12 pm
Forum: Compiler / Linking / IDE Related
Topic: Cannot build with "system" jpeg lib
Replies: 9
Views: 3770

Re: Cannot build with "system" jpeg lib

I am building wxWidgets through Visual Studio 2010 (using the solution). I did replace the include directory for the jpeg source, that's all there is to do when building static libs. I looked some at those CMake scripts, but I did not see anything that could help me with my problem. Appreciate the a...
by Warepire
Wed Jan 08, 2014 8:52 pm
Forum: Compiler / Linking / IDE Related
Topic: Cannot build with "system" jpeg lib
Replies: 9
Views: 3770

Re: Cannot build with "system" jpeg lib

The linux version allows to use the system lib of libjpeg instead of the included one, why would it be against the license to do this on Windows? Isn't it the same license for all platforms? Seemed like it was when I read it. The project is supposed to be cross-platform in the future, it's the purpo...
by Warepire
Tue Jan 07, 2014 6:56 pm
Forum: Compiler / Linking / IDE Related
Topic: Cannot build with "system" jpeg lib
Replies: 9
Views: 3770

Cannot build with "system" jpeg lib

Hi First off, forgive me if this is supposed to be somewhere else, this section looked more appropriate. Please move it to the correct place otherwise. I am trying to add wxWidgets to a project, since the project already depends on libjpeg v9 I thought I could link with only that instead of the wxjp...