Search found 81 matches

by guzzi_jones
Thu Feb 11, 2016 1:41 pm
Forum: General Development
Topic: wxPython pdb.set_trace() after event fires
Replies: 1
Views: 435

Re: wxPython pdb.set_trace() after event fires

It appears that winpdb is the answer here. http://winpdb.org/tutorial/WinpdbTutorial.html here is the divisible.py for future reference: import sys def is_divisible(a, b): """Determines if integer a is divisible by integer b.""" remainder = a % b # if there's no remaind...
by guzzi_jones
Wed Feb 10, 2016 7:46 pm
Forum: General Development
Topic: wxPython pdb.set_trace() after event fires
Replies: 1
Views: 435

wxPython pdb.set_trace() after event fires

It appears that my program outputs the results of pdb to a window rather than to the command line to allow my input commands such as "n" for next or "s " for sub. import wx import pdb class myPopupMenu(wx.Menu): def __init__(self,parent): super(myPopupMenu,self).__init__() pdb.se...
by guzzi_jones
Tue Feb 09, 2016 1:43 pm
Forum: General Development
Topic: wxPython best place to start; already know python
Replies: 1
Views: 508

wxPython best place to start; already know python

I have begun coding a GUI in wxPython using Python 2.7. I have found the following tutorial to start from. http://wiki.wxpython.org/Getting%20Started#Getting_started_with_wxPython I am forced to use python 2.7 and it uses wxpython 2.8 I have a good grasp of python , object oriented programming, etc ...
by guzzi_jones
Sat Apr 25, 2015 12:33 am
Forum: Compiler / Linking / IDE Related
Topic: codeblocks, debug editor turns grey
Replies: 0
Views: 698

codeblocks, debug editor turns grey

Why is it that even if i build against a debug version of wxWidgets I am still not able to evaluate the expression under the cursor while in the wxwidgets source code. The screen turns grey and none of the variables evaluate. Has anyone else experienced this. When i run the minimal sample in codeblo...
by guzzi_jones
Tue Apr 14, 2015 2:12 am
Forum: Compiler / Linking / IDE Related
Topic: codeblocks not finding headers , wx-config --cppflags [SOLVED]
Replies: 7
Views: 1588

Re: codeblocks not finding headers , wx-config --cppflags [SOLVED]

This was due to setting the path variable in my .bashrc instead of my .profile.
the path was apparently only set for bash and not sh which is what codeblocks uses to run the builds.
by guzzi_jones
Tue Apr 14, 2015 1:58 am
Forum: Compiler / Linking / IDE Related
Topic: codeblocks not finding headers , wx-config --cppflags [SOLVED]
Replies: 7
Views: 1588

Re: codeblocks not finding headers , wx-config --cppflags [SOLVED]

introducing a prebuild command:
`wx-config --cflags`
gives the following result:

Running project pre-build steps
`wx-config --cflags`
/bin/sh: 1: wx-config: not found
by guzzi_jones
Tue Apr 14, 2015 1:33 am
Forum: Compiler / Linking / IDE Related
Topic: codeblocks not finding headers , wx-config --cppflags [SOLVED]
Replies: 7
Views: 1588

Re: codeblocks not finding headers , wx-config --cppflags [SOLVED]

FYI ,
I resort to copying the results of
wx-config --cppflags
directly into the compiler options under Project | build options.

Everything compiles now., unfortunately I will need to do it this way.
by guzzi_jones
Tue Apr 14, 2015 1:26 am
Forum: Compiler / Linking / IDE Related
Topic: codeblocks not finding headers , wx-config --cppflags [SOLVED]
Replies: 7
Views: 1588

Re: codeblocks not finding headers , wx-config --cppflags [SOLVED]

Here is the whole project.
It is the most basic project, but won't compile.
by guzzi_jones
Tue Apr 14, 2015 12:57 am
Forum: Compiler / Linking / IDE Related
Topic: codeblocks not finding headers , wx-config --cppflags [SOLVED]
Replies: 7
Views: 1588

Re: codeblocks not finding headers , wx-config --cppflags [SOLVED]

Still not working.
This is so confusing. why is it not expanding the parameters?
by guzzi_jones
Tue Apr 14, 2015 12:39 am
Forum: Compiler / Linking / IDE Related
Topic: codeblocks not finding headers , wx-config --cppflags [SOLVED]
Replies: 7
Views: 1588

Re: codeblocks not finding headers , wx-config --cppflags [SOLVED]

version of codeblocks is svn build rev 10209.
I am going to try another rev or a stable rev. It is NOT doing the parameter expansion.
by guzzi_jones
Tue Apr 14, 2015 12:21 am
Forum: Compiler / Linking / IDE Related
Topic: codeblocks not finding headers , wx-config --cppflags [SOLVED]
Replies: 7
Views: 1588

Re: codeblocks not finding headers , wx-config --cppflags [SOLVED]

Also it is clear in the build log that is is NOT passing the wx-config flags: g++ -Wall -g -c /home/ajonen/t3/t3App.cpp -o obj/Debug/t3App.o In file included from /home/ajonen/t3/t3App.cpp:10:0: /home/ajonen/t3/t3App.h:13:20: fatal error: wx/app.h: No such file or directory compilation terminated. P...
by guzzi_jones
Mon Apr 13, 2015 11:54 pm
Forum: Compiler / Linking / IDE Related
Topic: codeblocks not finding headers , wx-config --cppflags [SOLVED]
Replies: 7
Views: 1588

codeblocks not finding headers , wx-config --cppflags [SOLVED]

I have compiled wxwidgets: wx-config --list outputs: Default config is gtk2-unicode-static-3.0 Default config in /usr/share/wxWidgets-3.0.2/wxUniDebugStatic will be used for output The path appears to be set. Everytime I attempt to compile i get wx/app.h cannot be found. It is like it is not running...
by guzzi_jones
Thu Feb 05, 2015 2:14 pm
Forum: C++ Development
Topic: How to convert wxString type to char* type ?
Replies: 5
Views: 636

Re: How to convert wxString type to char* type ?

thanks PB.
One clarification, though. I didn't use wxstring.c_str(). I first created a str::string object and then used string.c_str().

I am still learning c++ , (obviously), and really appreciate your feedback.
by guzzi_jones
Thu Feb 05, 2015 12:42 am
Forum: C++ Development
Topic: How to convert wxString type to char* type ?
Replies: 5
Views: 636

Re: How to convert wxString type to char* type ?

What exactly is a temporary pointer? Is there a link to a tutorial to explain that? * edit* it is an object created on the stack. so it is not created with new and is automatically deleted when it goes out of scope . since char * is also a pointer it is setting it's address to the address returned b...
by guzzi_jones
Thu Jan 15, 2015 4:30 pm
Forum: General Development
Topic: Event class simple question
Replies: 6
Views: 1188

Re: Event class simple question

That was totally what i was missing! I just went through a whole delegate tutorial on wibit.net and I was losing it as to how the event processing could call the method without the function AND the pointer to the class. It is being SET by default. duh. Thanks for the info. The cloud lifted enough th...

Go to advanced search