Search found 194 matches

by biplab
Wed Jul 21, 2010 7:06 am
Forum: Compiler / Linking / IDE Related
Topic: [2.9.1] Compiling wxWidgets-2.9.1 with MinGW [Error 1]
Replies: 26
Views: 7229

There are two ways. (I'm assuming release build is being built) 1) Change DEBUG_FLAG ?= 0 inside config.gcc file or issue DEBUG_FLAG=0 when enter make command in command prompt. 2) Manually edit setup.h file - uncomment line no 69 to 73 and then build. Please note that you can build multi-lib build....
by biplab
Mon Dec 03, 2007 6:40 pm
Forum: Compiler / Linking / IDE Related
Topic: Linking problem with Visual C++ 2008 Express & wxWidgets
Replies: 4
Views: 1397

Re: Linking problem with Visual C++ 2008 Express & wxWid

If I do the folowing to build wxWidgets : nmake -f makefile.vc BUILD=release nmake -f makefile.vc BUILD=debug If you do this, this implies that you have built your wx lib dynamically against CRT (C Runtime Library). I get the following compilation errors : link /NOLOGO /OUT:GraphPlot.exe /LIBPATH:c...
by biplab
Sat Sep 15, 2007 6:59 pm
Forum: Compiler / Linking / IDE Related
Topic: WxFormbuilder and overwritting of files
Replies: 7
Views: 2797

Create another class from the wxFormBuilder generated class. Then add your own code to the new class. You can refer the sample wxWidgets code generated by the wxWidgets wizard of a Latest Nightly Build of Code::Blocks. You can download it from the link provided in my signature. :) You'll get an work...
by biplab
Fri Sep 14, 2007 10:27 am
Forum: Compiler / Linking / IDE Related
Topic: Newbie - Install OK on Fedora - How do I open the IDE?
Replies: 7
Views: 1033

Re: Newbie - Install OK on Fedora - How do I open the IDE?

The install instructions tell me about compiler parameters but I thought I installed an IDE??? The command "whereis" does not find the source directory but then perhaps I don't know what to search for. I looked quickly at a couple tutorials but that didn't get me started. Yes, I am a newbie to wxWi...
by biplab
Wed Sep 12, 2007 5:42 pm
Forum: Compiler / Linking / IDE Related
Topic: SetIcon reports "undeclared identifier"
Replies: 2
Views: 515

Change the code to the following one.

Code: Select all

SetIcon(wxICON(appicon));
Please note that the macro wxICON() can be used in such way (Not the wxIcon class). :)
by biplab
Tue Aug 28, 2007 8:17 am
Forum: Compiler / Linking / IDE Related
Topic: How to build libraries with makefiles ?
Replies: 6
Views: 1490

You've to specify the include directories where the stdio.h and other header files reside. I don't use wxDevC++ so I'm not sure where do they exist. But let's say the the stdio.h is in C:\Program File\wxDevCPP\mingw\include then you can specify that to the makefile as mingw32-make -f makefile.gcc CF...
by biplab
Fri Jul 13, 2007 4:32 pm
Forum: Compiler / Linking / IDE Related
Topic: Setting up wxWidgets for the first time (using Code::blocks)
Replies: 13
Views: 2122

Get a newer Code::Blocks from the following forum.
Compiler need the path where your wx libs exist. Your project path don't have them. I'm talking about the wxPack installation path.
by biplab
Fri Jul 13, 2007 4:24 pm
Forum: Compiler / Linking / IDE Related
Topic: Setting up wxWidgets for the first time (using Code::blocks)
Replies: 13
Views: 2122

When Code::Blocks' wxWidgets wizard ask you to specify the wxWidgets location, point it to the location where u installed wxpack. Wizard will do the rest.
by biplab
Fri Jul 13, 2007 3:00 pm
Forum: Compiler / Linking / IDE Related
Topic: Setting up wxWidgets for the first time (using Code::blocks)
Replies: 13
Views: 2122

Blanchy wrote:Is there a precompiled version?
A pre-compiled version is available at the following url.
It has an older version, though. :)
by biplab
Fri Jul 13, 2007 2:36 pm
Forum: Compiler / Linking / IDE Related
Topic: Setting up wxWidgets for the first time (using Code::blocks)
Replies: 13
Views: 2122

I've sort of made a bit of progress, I included C:\wxWidgets-2.8.4\include\ into my IDE and so it no longer gives me a huge stream of errors, If you provide correct top-level directory to wxWidgets wizard of Code::Blocks, this step is not necessary. ld.exe cannot find -lwxmsw You've downloaded the ...
by biplab
Wed Jul 04, 2007 7:15 am
Forum: Compiler / Linking / IDE Related
Topic: wxDialog works with DLL, normal wxApp doesn't... Please help
Replies: 2
Views: 698

I don't think you can insert an app inside a dll.

A dll would have one WinMain and your app will insert another. :)

IMHO, this conflict is crashing your app.
by biplab
Wed Jul 04, 2007 7:11 am
Forum: Compiler / Linking / IDE Related
Topic: Linker Errors?
Replies: 3
Views: 1279

Re: Linker Errors?

Here is the compiler output: Compiler: Default compiler Building Makefile: "F:\Users\User\Projects\Hello World 2\Makefile.win" Executing make... make.exe -f "F:\Users\User\Projects\Hello World 2\Makefile.win" all g++.exe HelloWorldApp.o -o "Hello World 2.exe" -L"F:/Dev-Cpp/lib" -L"F:/wx/msw-debug/l...
by biplab
Tue Jul 03, 2007 3:15 am
Forum: Compiler / Linking / IDE Related
Topic: Unresolved externals after compiling libraries
Replies: 2
Views: 1897

You are mixing wx library linked against static CRT with the app compiled and linked against dynamic CRT.

Use similar configuration (static or dynamic CRT) for Both lib and app to avoid such errors.
by biplab
Tue Jul 03, 2007 3:11 am
Forum: Compiler / Linking / IDE Related
Topic: Code::Blocks problems
Replies: 7
Views: 1057

Re: Code::Blocks problems

PythonRulz wrote: C:\wxWidgets-2.8.4 196 wx/Setup.h No such file or directory
This indicates that you didn't compile wxWidgets source (which you've downloaded from wxWidgets site). Please compile it first before you can start compiling your app.
by biplab
Tue Jul 03, 2007 3:06 am
Forum: Compiler / Linking / IDE Related
Topic: link problem
Replies: 6
Views: 1283

You've compiled wx in Unicode mode and it seems that you are compiling your app in Non-Unicode mode.

Please check Enable Unicode in the Code::Blocks wxWidgets wizard to generate a new project and compile it.