Search found 46 matches

by ionone
Thu Jan 09, 2014 2:28 pm
Forum: C++ Development
Topic: wxWidgets showModal crashes VST plugin
Replies: 0
Views: 512

wxWidgets showModal crashes VST plugin

Hello i'm trying to use the File/Message Dialog into a VST plugin i use WDOL to ease plugin development wxBell() works so the library is correctly implemented i assume. The code i use is basic : wxMessageDialog *dial = new wxMessageDialog(NULL, wxT("Download completed"), wxT("Info"), wxOK); dial->Sh...
by ionone
Wed Sep 25, 2013 11:46 am
Forum: Compiler / Linking / IDE Related
Topic: trying to make the 64 bits version of wxWidgets working
Replies: 64
Views: 10012

Re: trying to make the 64 bits version of wxWidgets working

ohoh something strange happenend. I had forgotten some code that i had silenced, so i put back the code, and i had a lot of errors. This was the class for a panel (previewPanel). As soon as i included wx/panel.h or wx/wx.h i had the errors. so i tranfered everything to another .h file where i had al...
by ionone
Tue Sep 24, 2013 3:13 pm
Forum: C++ Development
Topic: crash when importing a PNG
Replies: 2
Views: 758

Re: crash when importing a PNG

You should always use wxBitmap::IsOk to check if a bitmap is ok. Apparently it wasn't loaded correctly, but it's hard to tell why. Are you sure the resource name is correct? thanks actually i managed to get rid of the errors. first i looked at the value of dem and it was 0000000 so i thought that t...
by ionone
Tue Sep 24, 2013 2:04 pm
Forum: Compiler / Linking / IDE Related
Topic: trying to make the 64 bits version of wxWidgets working
Replies: 64
Views: 10012

Re: trying to make the 64 bits version of wxWidgets working

okay so it is working i guess, even if i didn't go through testing everything, but all compiles now. So here is what i did step by step to make it compile. I use Visual Studio Express 2010. 1) first you need to install Windows SDK 7.1 to be able to compile 64 bits programs. If you have an error, try...
by ionone
Tue Sep 24, 2013 1:45 pm
Forum: C++ Development
Topic: crash when importing a PNG
Replies: 2
Views: 758

crash when importing a PNG

Hi i'm trying to import a PNG from a resource and display it. i followed the tuto at this page : http://wiki.wxwidgets.org/Embedding_PNG_Images and i'm embedding the file using the resource rc file. i add : wxInitAllImageHandlers(); dem = CreateBitmapFromPngResource(wxT("DEMARR")); to my constructor...
by ionone
Tue Sep 24, 2013 8:47 am
Forum: Compiler / Linking / IDE Related
Topic: trying to make the 64 bits version of wxWidgets working
Replies: 64
Views: 10012

Re: trying to make the 64 bits version of wxWidgets working

okay i found my error, i just had to add #define USE_SSE2 in the beginning of the h file and it compiles! i will put later a full configuration of my project, for peaople like me trying to use Photoshop API+wxwidgets, though it works on 2.8 not 2.9
by ionone
Tue Sep 24, 2013 7:51 am
Forum: Compiler / Linking / IDE Related
Topic: trying to make the 64 bits version of wxWidgets working
Replies: 64
Views: 10012

Re: trying to make the 64 bits version of wxWidgets working

i didn't use the daily snapshot , i compiled v2.9.5 and the libraries are in their folder ok, only wxbase29.lib isn't. i'm step by step compiling my plugin and i've came to an issue : i've included a library that compute 4 sin/cos/log/exp at a time, so it's a significant gain of speed. The only thin...
by ionone
Mon Sep 23, 2013 4:10 pm
Forum: Compiler / Linking / IDE Related
Topic: trying to make the 64 bits version of wxWidgets working
Replies: 64
Views: 10012

Re: trying to make the 64 bits version of wxWidgets working

okay so i started again but with version 2.8. I know it is not supposed to work, but it was working with 32 bits, no ? So i could compile a small program including some wx headers with no errors. But as soon as i switch to 2.9 ( i just change the folders) i have : wxbase2.9.lib not found error...grr...
by ionone
Mon Sep 23, 2013 3:31 pm
Forum: Compiler / Linking / IDE Related
Topic: trying to make the 64 bits version of wxWidgets working
Replies: 64
Views: 10012

Re: trying to make the 64 bits version of wxWidgets working

doublemax wrote:I have no idea where the wxbase29.lib comes from. Try a manual text search in the project files. Maybe it gives you a hint where to look.
i already did that and it found no trace unfortunately

i think i'll start from the plugin Dissolve once again
by ionone
Mon Sep 23, 2013 2:51 pm
Forum: Compiler / Linking / IDE Related
Topic: trying to make the 64 bits version of wxWidgets working
Replies: 64
Views: 10012

Re: trying to make the 64 bits version of wxWidgets working

*GASP* still trying to find wxbase29.lib

edit: okay i put to ignore a bunch of these libraries, then at the end i finish with 610 unresolved externals (!)
i'm desperate
by ionone
Mon Sep 23, 2013 2:48 pm
Forum: Compiler / Linking / IDE Related
Topic: trying to make the 64 bits version of wxWidgets working
Replies: 64
Views: 10012

Re: trying to make the 64 bits version of wxWidgets working

even if i changed the include and lib folders to math the compiled one, the compiler search in the wrong folder, the old one ;|

edit: oops my bad, forgot to change addtional dependencies
by ionone
Mon Sep 23, 2013 2:46 pm
Forum: Compiler / Linking / IDE Related
Topic: trying to make the 64 bits version of wxWidgets working
Replies: 64
Views: 10012

Re: trying to make the 64 bits version of wxWidgets working

okay i compiled everything with 0 errors nice! but when i want to compile my program, i have this error once again : 1>LINK : fatal error LNK1104: cannot open file 'wxbase29.lib' i don't understand why my program tries to find the non unicode version at all cost! i've never included anything or put ...
by ionone
Mon Sep 23, 2013 2:25 pm
Forum: Compiler / Linking / IDE Related
Topic: trying to make the 64 bits version of wxWidgets working
Replies: 64
Views: 10012

Re: trying to make the 64 bits version of wxWidgets working

Which source archive did you download? If you used a daily build or got it from SVN, you have to go to: <wx>/include/wx/msw/ and copy "setup0.h" to "setup.h". (You could just rename it, but it's better to keep the original "setup0.h") location is ..\..\lib\vc_lib\mswu\wx\setup.h not /include/wx/msw...
by ionone
Mon Sep 23, 2013 2:12 pm
Forum: Compiler / Linking / IDE Related
Topic: trying to make the 64 bits version of wxWidgets working
Replies: 64
Views: 10012

Re: trying to make the 64 bits version of wxWidgets working

wow nice, it didn't work in v2.8 but now i can open the files...

but when i try to compile wx regex i have an error message:
1> Creating ..\..\lib\vc_lib\mswu\wx\msw\rcdefs.h
1> genrcdefs.h
1> Creating ..\..\lib\vc_lib\mswu\wx\setup.h
1> file not found

there isn't the file setup.h

Jeff
by ionone
Mon Sep 23, 2013 1:11 pm
Forum: Compiler / Linking / IDE Related
Topic: trying to make the 64 bits version of wxWidgets working
Replies: 64
Views: 10012

Re: trying to make the 64 bits version of wxWidgets working

and for the previous issue i added #define _UNICODE 1 in the setup.h

weird to do that i agree but if not _UNICODE isn't defined....