Search found 131 matches

by JPlaroche
Mon Jun 24, 2013 4:26 pm
Forum: wxCode
Topic: wxpdfdoc police cmc7 [SOLVED]
Replies: 2
Views: 2371

Re: wxpdfdoc police cmc7

Thank you :P
by JPlaroche
Mon Jun 10, 2013 3:26 pm
Forum: wxCode
Topic: wxpdfdoc police cmc7 [SOLVED]
Replies: 2
Views: 2371

wxpdfdoc police cmc7 [SOLVED]

bonjour ULRICH, ici jean-pierre
hello,

I would use cmc7 Police

Is it possible to use this thank you wxpdfdoc with Police
@ soon


bonjour,

je voudrais utiliser police cmc7

est-il possible de ce servir de wxpdfdoc avec cette police merci
@bientot
by JPlaroche
Mon Jul 02, 2012 8:05 pm
Forum: Compiler / Linking / IDE Related
Topic: choice behavior change source 2.8 ->2.9.1 HELP??
Replies: 6
Views: 2564

Re: choice behavior change source 2.8 ->2.9.1 HELP??

#if wxUSE_UNICODE #define _UU(x,y) wxString((x),(y)) #define _CC(x,y) (x).mb_str((y)) #else #define _UU(x,y) (x) #define _CC(x,y) (x) #endif #define _U(x) _UU((x),wxConvUTF8) #define _C(x) _CC((x),wxConvUTF8) enfin de compte j'ai appliqué cette formule et je n'ai plus de problème bien sur pout toute...
by JPlaroche
Tue Aug 31, 2010 6:50 am
Forum: Compiler / Linking / IDE Related
Topic: choice behavior change source 2.8 ->2.9.1 HELP??
Replies: 6
Views: 2564

Hi, going from wx2.8 ANSI (non-unicode) to wx2.9/3.0 Unicode does not require any special changes to strings. Generally speaking you do not need any of these macros; just write the strings without macros (the notable exception being when you use methods from wxString, of course) If you get compilat...
by JPlaroche
Sat Aug 28, 2010 1:13 am
Forum: Compiler / Linking / IDE Related
Topic: choice behavior change source 2.8 ->2.9.1 HELP??
Replies: 6
Views: 2564

Re: choice behavior change source 2.8 ->2.9.1 HELP??

just to understand better how one can go from 2.9.1 to wx2.8 first, is it from 2.8 to 2.9, or from 2.9 to 2.8 ? You mentionned both so I'm confused. Your post is a bit confusing all in all, what is exactly your question? If you don't have to support 2.8, I recommend going to 2.9, there wxString can...
by JPlaroche
Fri Aug 27, 2010 10:17 pm
Forum: Compiler / Linking / IDE Related
Topic: choice behavior change source 2.8 ->2.9.1 HELP??
Replies: 6
Views: 2564

choice behavior change source 2.8 ->2.9.1 HELP??

compilateur GCC 4.4.5 wxwidgets 2.8.1 --> 2.9.1 IDE codeblock we must choose this formula to transform our developments ANSI to Unicode http://wiki.codeblocks.org/index.php?title=Unicode_Standards example: #ifdef wxUSE_UNICODE #define _U(x) wxString((x),wxConvUTF8) #define _UU(x,y) wxString((x),y) #...
by JPlaroche
Sat Aug 21, 2010 8:07 am
Forum: C++ Development
Topic: conversion wx2.8 to wx2.9 help
Replies: 3
Views: 828

tan wrote:Hi,
just remove wxT(...) macros. Its usage in such context incorrectly anyway :)

thank you :oops: :lol: :lol: :lol:
by JPlaroche
Sat Aug 21, 2010 3:01 am
Forum: C++ Development
Topic: conversion wx2.8 to wx2.9 help
Replies: 3
Views: 828

conversion wx2.8 to wx2.9 help

bool wx_Date::Setdate(wxString V_date ) { size_t ntest ; nyear = wxAtoi(V_date.SubString(0, 3)); nmonth = wxAtoi(V_date.SubString(4, 5)); nday = wxAtoi(V_date.SubString(6, 7)); if ( nyear < 2000 ) return true; if ( nmonth == 0 || nmonth > 12 ) return true; if ( nday == 0 || nday > 31 ) return true;...
by JPlaroche
Tue Feb 09, 2010 9:59 am
Forum: Platform Related Issues
Topic: programme not reponse windows7
Replies: 0
Views: 355

programme not reponse windows7

please

Gcc 4.
wxwidgets 2.8.9 codebloock

hi

run pgm and click my programme ohter windows or frame

my frame is transparente not active

not(probleme xp) just windows 7

thank you
by JPlaroche
Tue Apr 07, 2009 12:51 am
Forum: Platform Related Issues
Topic: GTK to link wxwidget codeblock
Replies: 2
Views: 950

Hi, The essential usage of wx-config is `wx-config --libs --cxxflags` If you're not using --libs elsewhere, you should be. If that's not the answer, maybe the wx build you're using (what version is it btw?) was built to link against the ubuntu regex lib, and that lib is missing from your current in...
by JPlaroche
Sat Apr 04, 2009 11:39 pm
Forum: Platform Related Issues
Topic: GTK to link wxwidget codeblock
Replies: 2
Views: 950

GTK to link wxwidget codeblock

`wx-config --version=2.8 --static=no --unicode=no --debug=yes --cflags` log /home/jpmf/wx_lib/wxMask/Mask.cpp|31|erreur: ‘wxRE_ADVANCED’ was not declared in this scope| my project is good win32 exact idem project is problem ubuntu ????????? help bool MaskTextCtrl::MaskIsUDigit(const int Mskkey) { wx...
by JPlaroche
Tue Mar 24, 2009 3:48 pm
Forum: C++ Development
Topic: dif xdate.GetMonth(); and wxAtoi(xdate.Format("%m"
Replies: 1
Views: 790

dif xdate.GetMonth(); and wxAtoi(xdate.Format("%m"

I 'have problem why the resultat is different enters wxDateTime: : GetMonth () = 2 for 20090324 and wxDateTime ::.Format (" % m") 03 for 20090324 help help help j'ai un problème =========================================================== void TimeStamp(otl_datetime tm) { wxDateTime xdate = wxDateTim...
by JPlaroche
Thu Mar 12, 2009 7:24 pm
Forum: C++ Development
Topic: wxODBC and wxwidgets 2.9 > 3.....
Replies: 8
Views: 1713

I face the same problem. I also hope to keep wxODBC in the future version before a better replacement is found. Also the current package lack of a report writer. It's a pity. je travail avec AS400 V5R4 and V6R1 bonjour j'ai trouvé une lib qui marche parfaitement avec DB2 etc.... je suis en plein TE...
by JPlaroche
Wed Mar 11, 2009 9:54 pm
Forum: C++ Development
Topic: wxODBC and wxwidgets 2.9 > 3.....
Replies: 8
Views: 1713

The reason that wxODBC was removed from wxWidgets in 2.9+ is because it was supposedly broken with changes to wxString in 2.9, and no-one was willing to spend the time to fix it, so it's actually very unlikely that you will be able to use wxODBC with wxWidgets 2.9+. You can't just mix and match lib...
by JPlaroche
Wed Mar 11, 2009 1:45 pm
Forum: C++ Development
Topic: wxODBC and wxwidgets 2.9 > 3.....
Replies: 8
Views: 1713

It sounds like your wanting features from one version of wxWidgets but you want to use the main body of another. If thats the case, I think it safe to copy the features and integrate them yourself into the version of wxWidgets that you want. Then just recompile. merci, oui je veux utiliser wxwidget...