Search found 40 matches

by Dandel1984
Sat Jun 10, 2006 2:26 am
Forum: Compiler / Linking / IDE Related
Topic: compiling problems
Replies: 1
Views: 765

C:\wxWidgets\src\generic\listctrl.cpp(5578) : error C2562: 'DoClientToScreen' : 'void' function returning a value ..\..\include\wx/generic/listctrl.h(256) : see declaration of 'DoClientToScreen' C:\wxWidgets\src\generic\listctrl.cpp(5583) : error C2562: 'DoScreenToClient' : 'void' function returnin...
by Dandel1984
Thu Jun 08, 2006 4:39 am
Forum: Compiler / Linking / IDE Related
Topic: Building a linux wx app that runs on other PC's but mine
Replies: 8
Views: 2149

i must also concure that premake helps a lot, and as for the configuration/compilation, try the following commands and see if it helps at all, for configuration and compilation...

wx-config --cxxflags
wx-config --libs

and as for the linking, try adding the flag "--static" for static links.
by Dandel1984
Wed Jun 07, 2006 12:17 am
Forum: Compiler / Linking / IDE Related
Topic: Building a linux wx app that runs on other PC's but mine
Replies: 8
Views: 2149

i don't know what it is doing, but did you try installing the library or static linking of it?
by Dandel1984
Wed Jun 07, 2006 12:12 am
Forum: Compiler / Linking / IDE Related
Topic: wxMSW won't configure
Replies: 5
Views: 1056

Well this is a dead lost cause. I gave up and had success with the free visual c++ express development environment. i use mingw myself it's not a lost cause... here's what you gotta do.. 1) start up command prompt and add the bin directory of mingw to the path. 2) go to the build\msw directory unde...
by Dandel1984
Sun Jun 04, 2006 9:50 pm
Forum: General Development
Topic: Need help in UDP "connection"
Replies: 10
Views: 1400

Do you mean I should read the wxWidgets manual, I should use the wxSockXxxx API? Currently I only use wxWidgets as a GUI solution. I don't quite get your point. all that i was pointing out is how to set wxwidgets with a shut off routine that can be used with the initialization routine... and as for...
by Dandel1984
Sun Jun 04, 2006 2:08 am
Forum: General Development
Topic: Need help in UDP "connection"
Replies: 10
Views: 1400

i would read this document, since it appears to have some real good helpful advice for your current circumstance... http://alug.appstate.edu/index.php?module=wiki&page=WxWidgetsDevelopment I am sorry, but i can't find the "some real good helpful advice" anywhere. Do I have to login that page? i sai...
by Dandel1984
Sat Jun 03, 2006 5:18 am
Forum: Compiler / Linking / IDE Related
Topic: ldconfig and can't run demos
Replies: 1
Views: 385

did you try the pretty much standard command, "make install" when compiling wxwidgets?
by Dandel1984
Sat Jun 03, 2006 5:09 am
Forum: General Development
Topic: Need help in UDP "connection"
Replies: 10
Views: 1400

i would read this document, since it appears to have some real good helpful advice for your current circumstance...

http://alug.appstate.edu/index.php?modu ... evelopment
by Dandel1984
Sat Jun 03, 2006 5:00 am
Forum: Compiler / Linking / IDE Related
Topic: problem compiling fromDll with 2.6.3 under WinXP & MSVC6
Replies: 6
Views: 1226

i would look at your files after reading this... http://www.wxwindows.org/manuals/2.6.3/wx_librarieslist.html look at your wxwidgets directory where you find wxbase26 and find the file that has QA on it, because there should be no reason for it to exist, but it might be under a different name than y...
by Dandel1984
Sat Jun 03, 2006 4:44 am
Forum: Compiler / Linking / IDE Related
Topic: Link error, please help
Replies: 5
Views: 1447

i have 4 quick questions for some idea as to what's going wrong.. 1) what was the make command you used to compile wxwidgets ( if you don't know recompile it ) 2) did the samples and some of the contributed files compile properly when you tried? 3) what is the libraries you are linking against? 4) w...
by Dandel1984
Sat Jun 03, 2006 4:22 am
Forum: Compiler / Linking / IDE Related
Topic: Link error in Visual Studio 2005 pro (SOME errors inside)
Replies: 6
Views: 1673

jjoe wrote:To Jorg and cpp:

Both methods don't work for me.
can you please recompile wxwidgets, and it's samples and see if it works, because that might help... oh and don't forget to retry yours using the same applicable settings.
by Dandel1984
Sat Jun 03, 2006 4:09 am
Forum: Compiler / Linking / IDE Related
Topic: Zlib problem while compiling wxX11
Replies: 2
Views: 863

i have 3 or 4 questions for you about your system... to help with fixing this... 1) Do you have GTK installed? 2) Do you have a local install of Zlib? 3) What is the command you used to start the configure then compile, because that will effect how it goes. 4) what version of gcc, make, and autotool...
by Dandel1984
Sat Jun 03, 2006 3:54 am
Forum: Compiler / Linking / IDE Related
Topic: Using wxAssert & wzMessageBox from a DLL
Replies: 4
Views: 873

At first glance it does seem to be doing something along the lines I am looking for., I think ;-) Unfortunately there are some major differences including a build environment which I can't reproduce, a lot of tools I'm unfamiliar with - premake and lua among the most important ones :( ok.... since ...
by Dandel1984
Sat Jun 03, 2006 12:48 am
Forum: Compiler / Linking / IDE Related
Topic: Is there any bug-free tutorial for setting up VC 2005 pro?
Replies: 2
Views: 566

Re: Is there any bug-free tutorial for setting up VC 2005 pr

Hello, I followed instructions in http://www.wxwidgets.org/wiki/index.php/Compiling_WxWidgets, which seems to be the most detailed one, but there are still many link errors appearing. I guess many people also encountered the same problem because there are many threads about link difficulties. Thank...
by Dandel1984
Thu Jun 01, 2006 9:24 pm
Forum: Compiler / Linking / IDE Related
Topic: Using wxAssert & wzMessageBox from a DLL
Replies: 4
Views: 873

i would take a look at how the wxnet project's WX-C file works... so download the file from here... http://wxnet.sourceforge.net ... it should help you considering it adds the C exports to wxwidgets, and you can link it to the wx-c dll instead of wxnet.dll in the end if you want.