Search found 21 matches

by alancan
Mon Dec 03, 2012 8:22 pm
Forum: wxDev-C++
Topic: wxTextCtrl borders not displaying
Replies: 2
Views: 2409

Re: wxTextCtrl borders not displaying

@doublemax - I have been working on one for the past while, but no luck reproducing problem at small scale, I may have to mock up a large portion program without specific details to re-create this problem... this may be the real problem anyways... On the bright side, I found a partial workaround. If...
by alancan
Thu Nov 15, 2012 3:17 pm
Forum: wxDev-C++
Topic: wxTextCtrl borders not displaying
Replies: 2
Views: 2409

wxTextCtrl borders not displaying

Hi, I'm curious if anyone else has encountered this. I am creating wxEdit (wxTextCtrl) objects dynamically, and they function correctly, except for one issue. When they are initially displayed or enabled/disabled some(but not always all of the wxtextctrls) lose their borders. This is really making m...
by alancan
Thu Nov 01, 2012 1:52 pm
Forum: wxDev-C++
Topic: 7.4.2.569 Many "duplicate section" warnings when compiling
Replies: 9
Views: 8526

Re: 7.4.2.569 Many "duplicate section" warnings when compili

PB, thanks for this, I am successfully able to do a "Rebuild All" and a "Clean" now, (Removed path to RTools (which contains it's own instance of gcc if that matters), fixed that for me).

This has solved my warning output problem, appreciate the help from all!

-Alan
by alancan
Tue Oct 30, 2012 8:08 pm
Forum: wxDev-C++
Topic: 7.4.2.569 Many "duplicate section" warnings when compiling
Replies: 9
Views: 8526

Re: 7.4.2.569 Many "duplicate section" warnings when compili

I have followed all of these procedures previously without luck, except for the Rebuild All. Well, clarification, I did attempt the Rebuild All, however it failed: del: not found mingw32-make.exe: *** [clean] Error 127 Execution terminated Compilation Failed. Make returned 2 So I am investigating th...
by alancan
Thu Sep 27, 2012 6:36 pm
Forum: wxDev-C++
Topic: 7.4.2.569 Many "duplicate section" warnings when compiling
Replies: 9
Views: 8526

Re: 7.4.2.569 Many "duplicate section" warnings when compili

@softport, I have been working on this same issue on/off for a month now, any luck so far? I have attempted to reinstall multiple times; including installing directly to C:/Dev-cpp to avoid the space in "Program Files", turned on unicode support, and updating the library to be lwxmsw29u and 29u_gl, ...
by alancan
Mon Dec 12, 2011 1:12 pm
Forum: wxDev-C++
Topic: Compile with different compiler?
Replies: 4
Views: 3033

Re: Compile with different compiler?

Tony, Essentially what you described (create a makefile for the linux machine), and run that on the linux server is what I'm doing now. When you spoke of gcc cross-compiling, that is what I was trying to achieve, but I think I will simply stick with the linux makefile that I have been using. When I ...
by alancan
Fri Dec 09, 2011 6:36 pm
Forum: wxDev-C++
Topic: Compile with different compiler?
Replies: 4
Views: 3033

Re: Compile with different compiler?

Well it seems as though it will not run, and it may be because I am compiling on a windows machine and then trying to use that executable to run on the unix machine. I have attempted to change the compiler type to linux gcc, but I end up with an error each time - or it simply does not work on the un...
by alancan
Fri Dec 09, 2011 2:35 pm
Forum: wxDev-C++
Topic: Compile with different compiler?
Replies: 4
Views: 3033

Compile with different compiler?

In short, what I have is a console based project, created in wxDev-C++, that has no wxwidgets included, that I'd like to run on my unix web server - as part of a web application. The issue that I see, and I could be wrong, is that wxdevc++ compiles with gcc 3.4.5 by default, and the unix web server ...
by alancan
Tue Dec 06, 2011 6:38 pm
Forum: wxDev-C++
Topic: 32 bit support from 64 bit platform?
Replies: 2
Views: 1594

Re: 32 bit support from 64 bit platform?

Thank you, just wanted to confirm this.

Cheers!
by alancan
Tue Dec 06, 2011 3:34 pm
Forum: wxDev-C++
Topic: 32 bit support from 64 bit platform?
Replies: 2
Views: 1594

32 bit support from 64 bit platform?

Hi,

I would simply like to know if I can still develop programs for 32 bit operating systems, if I switch to 64 bit Win 7 and create my programs from that machine. Are there options such as in Visual Studio where I can target the platform?

Thanks!

Alan
by alancan
Tue Nov 29, 2011 10:38 pm
Forum: wxDev-C++
Topic: undefined reference
Replies: 2
Views: 3705

Re: undefined reference

Thank you tbreina!

This has resolved my issue, though I had some errors some of my strings that I had not wrapped in wxT() or _T(), but I have resolved those issues and am able to continue working now!

Cheers! :D

Alan
by alancan
Tue Nov 29, 2011 2:13 pm
Forum: wxDev-C++
Topic: undefined reference
Replies: 2
Views: 3705

undefined reference

Hi, I just upgrade to wxDevC++ 7.4 and I am attempting to re-compile a program that I wrote in 7.3.1. I am having a Linker Error issue. I have already changed to unicode support. Below is a portion of the Compile log to view the issues, it pretty much repeats the same errors. Any ideas would be grea...
by alancan
Thu Nov 03, 2011 2:59 pm
Forum: wxDev-C++
Topic: Panels disappear when trying to re-pin
Replies: 3
Views: 1762

Re: Panels disappear when trying to re-pin

Thanks for the reply. When I am done with my project in a couple of weeks I will see if I can repeat this process.

Also, will try deleting the layout.ini as you have suggested if I am able to repeat the process.

Alan
by alancan
Wed Nov 02, 2011 6:37 pm
Forum: wxDev-C++
Topic: Panels disappear when trying to re-pin
Replies: 3
Views: 1762

Panels disappear when trying to re-pin

Hi, I just upgraded to the 7.4 release last week and things have been running smoothly for the most part. Today I attempted to re-pin the panels (Ex: Compile, Resources), and now they have disappeared completed. In View->Panels, they all show up as being ON, and if I attempt to uncheck/check again, ...
by alancan
Thu Mar 17, 2011 12:54 pm
Forum: wxDev-C++
Topic: wxdevcpp crash when opening project
Replies: 2
Views: 1398

I do delete the config file before re-installing. This is unfortunately a private project, and yes, it does have many bugs, so I'm not sure if this is something that my project is causing or not. The project is currently in the area of 8000-9000 lines and 47 source files, but I assume the IDE wouldn...