Search found 232 matches

by DavidKlecker
Fri Apr 07, 2017 4:52 pm
Forum: C++ Development
Topic: wxPropertyGrid Issue
Replies: 3
Views: 523

Re: wxPropertyGrid Issue

I guess I didn't make it clear that using the debugger is what resulting in me knowing the location of where the crash occurred. However knowing that location didn't really help in understanding why that particular variable was NULL. Further research into this doesn't really give me an exact answer....
by DavidKlecker
Thu Apr 06, 2017 2:45 pm
Forum: C++ Development
Topic: wxPropertyGrid Issue
Replies: 3
Views: 523

wxPropertyGrid Issue

I'm having a very strange issue with the wxPropertyGrid and I'm not sure what I need to be checking for so that I can either error out or fix the grid so this error doesn't happen. I have a TreeList Panel control, that is, it's like the tab control but instead of tabs I have the treelist on the left...
by DavidKlecker
Thu Apr 06, 2017 2:35 pm
Forum: Compiler / Linking / IDE Related
Topic: Building a project on ubuntu - will not link - undefined reference
Replies: 16
Views: 2441

Re: Building a project on ubuntu - will not link - undefined reference

So I have the correct development libraries installed, yet error continues to come up Do: sudo apt-cache search wxgtk (or look in e.g. synaptic) and you'll see that the media and webview libs and dev packages are separate. You need to install whichever of those that you need and aren't currently in...
by DavidKlecker
Sat Apr 01, 2017 2:32 pm
Forum: Compiler / Linking / IDE Related
Topic: Building a project on ubuntu - will not link - undefined reference
Replies: 16
Views: 2441

Re: Building a project on ubuntu - will not link - undefined reference

I have a couple more clues that might help: 1) when I actually just use `wx-config --libs all` in my linker build options I get the following error "/usr/bin/ls: cannot find -lwx_gtk2u_media3.0" Now this is interesting because if I just put it the actual value for wx-config --libs all I do not see t...
by DavidKlecker
Sat Apr 01, 2017 10:40 am
Forum: Compiler / Linking / IDE Related
Topic: Building a project on ubuntu - will not link - undefined reference
Replies: 16
Views: 2441

Re: Building a project on ubuntu - will not link - undefined reference

I tried to run the application by just double clicking the actual application in the folder window. It won't start up. I haven't tried to use the terminal to run it. That's an interesting alternative to try. Didn't think of that. I have tried the debugger. Actually that was the first thing I tried h...
by DavidKlecker
Fri Mar 31, 2017 10:39 pm
Forum: Compiler / Linking / IDE Related
Topic: Building a project on ubuntu - will not link - undefined reference
Replies: 16
Views: 2441

Re: Building a project on ubuntu - will not link - undefined reference

using wx-config --cflags vs wx-config --cxxflags makes no difference. They both return the exact same thing. It appears everything is compiling and linking... however it terminates on a status 127 with nothing to say why it terminated on status 127. Does anyone have a few ideas to explore on why I m...
by DavidKlecker
Fri Mar 31, 2017 4:25 pm
Forum: Compiler / Linking / IDE Related
Topic: Building a project on ubuntu - will not link - undefined reference
Replies: 16
Views: 2441

Re: Building a project on ubuntu - will not link - undefined reference

I can try that as well. Currently I am getting a Terminated on status 127. I understand what this means however there is no additional information from Code::Blocks that tells me why I am getting status 127. According the site FAQ it could be a invalid PATH or a typo. I checked my global settings to...
by DavidKlecker
Fri Mar 31, 2017 10:00 am
Forum: Compiler / Linking / IDE Related
Topic: Building a project on ubuntu - will not link - undefined reference
Replies: 16
Views: 2441

Re: Building a project on ubuntu - will not link - undefined reference

I noticed that I am using compiler flags that are for 3.0 and linker flags that are for 3.1. I'm not sure how that happened. I have conflicting results with wx-config --cflags. After further testing I don't think my application is ready for 3.1 so I am going to go back to 3.0. Hopefully that was the...
by DavidKlecker
Thu Mar 30, 2017 5:38 pm
Forum: Compiler / Linking / IDE Related
Topic: Building a project on ubuntu - will not link - undefined reference
Replies: 16
Views: 2441

Re: Building a project on ubuntu - will not link - undefined reference

I actually inputted the results for wx-config --libs all into the linker settings and just have wx-config --cflags in the compiler settings. I will double check but at first glance it seemed to be correct and match what I get from the terminal. However I will make sure that is the case here and repo...
by DavidKlecker
Thu Mar 30, 2017 2:01 pm
Forum: Compiler / Linking / IDE Related
Topic: Building a project on ubuntu - will not link - undefined reference
Replies: 16
Views: 2441

Re: Building a project on ubuntu - will not link - undefined reference

Thanks for the reply. So I looked into how I was compiling deeper. I do not have any debug information going into the compilation. I have nothing checked in the Compiler flags for Release Mode as well in the global mode. I do have the debugging flags checked for the debug mode. I am compiling in Rel...
by DavidKlecker
Wed Mar 29, 2017 6:01 pm
Forum: Compiler / Linking / IDE Related
Topic: Building a project on ubuntu - will not link - undefined reference
Replies: 16
Views: 2441

Building a project on ubuntu - will not link - undefined reference

Here we go again. *sigh* I have downloaded wxWidgets 3.1, compiled wxWidgets 3.1 using the following configure ../configure --enable webview --enable unicode and am trying to compile my project using codeblocks. I have placed the proper wxconfig calls in the right places but I continue to get the fo...
by DavidKlecker
Mon Feb 06, 2017 3:26 pm
Forum: Platform Related Issues
Topic: What application on OSX do I use to package my program into an installer?
Replies: 6
Views: 895

Re: What application on OSX do I use to package my program into an installer?

That site should do it. a DMG is just a packaged file so all the folders and structure should be present. I think this will work fine. Thanks for the link!
by DavidKlecker
Mon Feb 06, 2017 3:08 pm
Forum: Platform Related Issues
Topic: What application on OSX do I use to package my program into an installer?
Replies: 6
Views: 895

Re: What application on OSX do I use to package my program into an installer?

I don't work under OSX, but AFAIK you don't create an installer like you would under Windows. Instead you just create a .DMG image that has a link to the Applications folder and the user has to drag your app into that folder. http://ramezanpour.net/post/2014/05/12/how-to-create-installation-dmg-fil...
by DavidKlecker
Mon Feb 06, 2017 3:07 pm
Forum: Platform Related Issues
Topic: What application on OSX do I use to package my program into an installer?
Replies: 6
Views: 895

Re: What application on OSX do I use to package my program into an installer?

Hi, Did you compile it as a bundle? Thank you. It's possible. That would be the defining characteristic of that so I can check and the alternative characteristic if it is not? Also, if not, obviously then CodeBlocks doesn't automatically have this set which means I would have to set it. Do you happ...
by DavidKlecker
Sat Feb 04, 2017 5:44 pm
Forum: Platform Related Issues
Topic: What application on OSX do I use to package my program into an installer?
Replies: 6
Views: 895

What application on OSX do I use to package my program into an installer?

I guess the title says it all. I have compiled my wxWidgets program in OSX and now I need a way to package it into an installer so I can distribute it. It would be nice to get this into some kind of .DMG. I've looked around but some applications are junk. I was wondering if anyone here who uses OSX ...