Search found 14 matches

by AnotherCoder
Mon May 31, 2010 1:10 am
Forum: Compiler / Linking / IDE Related
Topic: Can't Build: "System cannot find path specified"
Replies: 3
Views: 1694

Well, if you get more problems, you can try this video guide for compiling the libraries: here.
by AnotherCoder
Mon Mar 01, 2010 4:20 pm
Forum: Compiler / Linking / IDE Related
Topic: How to set up wxWidgets using Microsoft Visual C++ 2008
Replies: 4
Views: 1150

I had the same problems, lol!

See these forum topics (I believe they are both resolved):
http://forums.wxwidgets.org/viewtopic.php?t=25282
http://forums.wxwidgets.org/viewtopic.php?t=25279
by AnotherCoder
Sat Feb 13, 2010 7:24 pm
Forum: Compiler / Linking / IDE Related
Topic: How to set up wxWidgets using Microsoft Visual C++ 2008
Replies: 4
Views: 1150

I tried the wxwidgets "official" guide, but it is really confusing.
This one is pretty good.
by AnotherCoder
Fri Feb 12, 2010 5:38 pm
Forum: Compiler / Linking / IDE Related
Topic: How to set up wxWidgets using Microsoft Visual C++ 2008
Replies: 4
Views: 1150

How to set up wxWidgets using Microsoft Visual C++ 2008

Hey guys,

Here is a guide some guy made to set up wxWidgets using Microsoft Visual C++ 2008:
http://amilkhanzada.blogspot.com/2010/0 ... osoft.html
by AnotherCoder
Mon Aug 24, 2009 8:07 pm
Forum: C++ Development
Topic: Unicode not working in wxWidgets GUI?
Replies: 9
Views: 3515

I got it working finally! I did the things above (like changing project settings, etc.) and changed the last function to: void MyFrame::OnAbout(wxCommandEvent& WXUNUSED(event)) { wxString temp(L"言語"); wxMessageBox(temp, _T("About Hello World"), wxOK | wxICON_INFORMATION, this); } And it works! Thank...
by AnotherCoder
Mon Aug 24, 2009 6:54 pm
Forum: C++ Development
Topic: Unicode not working in wxWidgets GUI?
Replies: 9
Views: 3515

Thanks for the answers. Do NOT forget turn on unicode flag in your project settings. For example, if you are using visual studio 2005, pls check "project properties -> Configuration Properties -> General -> Character Set" I made this change (from Multi-Byte to Unicode) in MS VC++ 2008. I built wxWid...
by AnotherCoder
Mon Aug 24, 2009 5:10 am
Forum: C++ Development
Topic: Unicode not working in wxWidgets GUI?
Replies: 9
Views: 3515

Re: Unicode not working in wxWidgets GUI?

Why bother?Below code does not meet what you want? wxString s=_T("言語"); wxMessageBox(s); No, I tried that way, but I got 2 warnings and the program still did not work: warning C4566: character represented by universal-character-name '\u8A00' cannot be represented in the current code page (1252) war...
by AnotherCoder
Mon Aug 24, 2009 2:19 am
Forum: C++ Development
Topic: Unicode not working in wxWidgets GUI?
Replies: 9
Views: 3515

Thanks. Here are the answers: - UTF-8 - Unicode (I guess cause it is Visual C++ 2008) - ? - wxWidgets should accept Unicode right? I tried running your code. It compiled, but I got either question marks or random ASCII characters. One thing might be that I only built wxWidgets libraries for Debug, R...
by AnotherCoder
Sun Aug 23, 2009 9:08 pm
Forum: C++ Development
Topic: Unicode not working in wxWidgets GUI?
Replies: 9
Views: 3515

Unicode not working in wxWidgets GUI?

Hi, I am new to wxWidgets and am using it in Microsoft Visual C++ 2008. I can get this program from the Hello World Tutorial running just fine. I already built wxWidgets libraries for Debug, Release, and Unicode - Release. I modified the last function of the Hello World program to: void MyFrame::OnA...
by AnotherCoder
Sun Aug 23, 2009 6:25 pm
Forum: C++ Development
Topic: Unicode not working in wxWidgets Windows Console?
Replies: 9
Views: 1876

Unicode in GUI?

Okay, I've changed the font, but I am still only getting: Press any key to continue . . . Well, I guess it is not so important to print Unicode in console. But, will Unicode work in normal GUI programs? EDIT: I'll just post a new topic with the Unicode in GUI applications: http://forums.wxwidgets.or...
by AnotherCoder
Sun Aug 23, 2009 5:58 pm
Forum: C++ Development
Topic: Unicode not working in wxWidgets Windows Console?
Replies: 9
Views: 1876

Well, the guide I read said that I needed to change the font Lucida Console, but I don't know how to do this :oops:

Also, the article said to use "%S" because "it tells the wprint function to expect narrow string"

Thanks for all your responses.
by AnotherCoder
Sun Aug 23, 2009 5:29 pm
Forum: C++ Development
Topic: Unicode not working in wxWidgets Windows Console?
Replies: 9
Views: 1876

Okay, now I am even more confused. After reading the article, I got this far: #include <wx/string.h> #include <wx/utils.h> #include <windows.h> int _tmain() { //Store the old console format in 'oldcp' UINT oldcp = GetConsoleOutputCP(); SetConsoleOutputCP(CP_UTF8); wchar_t s[] = L"aΣb"; int bufferSiz...
by AnotherCoder
Sun Aug 23, 2009 5:07 am
Forum: C++ Development
Topic: Unicode not working in wxWidgets Windows Console?
Replies: 9
Views: 1876

Thanks.
I will look at that link tomorrow.
Sorry, but I need to go now.

Will try to respond in less than 10 hours :oops:

EDIT: I updated the title in the first post.
by AnotherCoder
Sun Aug 23, 2009 2:45 am
Forum: C++ Development
Topic: Unicode not working in wxWidgets Windows Console?
Replies: 9
Views: 1876

Unicode not working in wxWidgets Windows Console?

Hi, I am new to wxWidgets and am using it in Microsoft Visual C++ 2008. I can get this program from the Hello World Tutorial running just fine. How come this program outputs question marks when I try to compile in release mode: #include <wx/string.h> int main(int argc, char **argv) { wxPuts(wxT("言語"...