Search found 15 matches

by !here&!there
Wed Jul 22, 2009 9:58 pm
Forum: C++ Development
Topic: POEdit and wxWidgets Unicode Build problem
Replies: 2
Views: 470

POEdit and wxWidgets Unicode Build problem

Hi, i am using unicode version of the library, and i am using POEdit to make the translation to German. In the ansii version i have had no problems with the use of MO files for the translation, but with the unicode build, i can not get it working. I am using utf-8 in the Catalog Settings under POEdi...
by !here&!there
Mon Jul 13, 2009 1:33 am
Forum: Platform Related Issues
Topic: wxTimerProc(): bogus timer id in wxTimerProc
Replies: 4
Views: 568

That is right t_1, t_2 and t_3 are members of MyFrame and they are initialized in MyFrame constructor. t_1 is started when User clicks a button, so t_1.Start(1000) is called in the button's event handler. After t_1.Stop() is called i am starting a worker thread that makes some work and upon finish i...
by !here&!there
Sun Jul 12, 2009 11:02 am
Forum: Platform Related Issues
Topic: wxTimerProc(): bogus timer id in wxTimerProc
Replies: 4
Views: 568

wxTimerProc(): bogus timer id in wxTimerProc

Hi, i am using 3 wxTimers as follows: wxTimer t_1(this, ID1); wxTimer t_2(this, ID2); wxTimer t_3(this, ID3); ..... EVT_TIMER( ID1, MyFrame::OnTimer1 ) EVT_TIMER( ID2, MyFrame::OnTimer2) EVT_TIMER( ID3, MyFrame::OnTimer3 ) ..... //this handler works fine void MyFrame::OnTimer1( wxTimerEvent& WXUNUSE...
by !here&!there
Sat Jul 04, 2009 5:26 pm
Forum: C++ Development
Topic: Memory leaks in dataview sample
Replies: 3
Views: 453

Ok, i have made 2 video to explain it:

http://www.mediafire.com/?sharekey=98af ... f6e8ebb871


It seems that the Mediaplayer sample has memory leaks too...

Download the videos to see it.
by !here&!there
Sat Jul 04, 2009 2:46 am
Forum: C++ Development
Topic: Memory leaks in dataview sample
Replies: 3
Views: 453

Memory leaks in dataview sample

Hi,

just quick info; it seems that the dataview sample has memory leaks. Check the Attachment for more details.
by !here&!there
Thu Jul 02, 2009 10:56 pm
Forum: Compiler / Linking / IDE Related
Topic: Linking error while building application for WinCE
Replies: 6
Views: 1392

Can you post screenshots of what you have under :
Configuration Properties->Linker->Input
and
Configuration Properties->Linker->General
by !here&!there
Thu Jul 02, 2009 3:10 am
Forum: Compiler / Linking / IDE Related
Topic: Linking error while building application for WinCE
Replies: 6
Views: 1392

From the error you are getting, it seems that you are linking to the wrong version of wxWidgets libraries. Try the following: Under: ------ Configuration Properties->Linker->Input:Additional Dependencies remove everything and put : coredll.lib wxwince28d.lib wxjpegd.lib wxpngd.lib wxzlibd.lib wxexpa...
by !here&!there
Tue Jun 30, 2009 9:58 pm
Forum: Compiler / Linking / IDE Related
Topic: Debugging App in Visual Studion 2008 Express very slow
Replies: 6
Views: 563

Well i think contacting Micro$oft is useless in this case. I have tested with different Operating Systems but no luck. I have digged deeper in the code, and found the suspected function :D causing this slowdown: wxImage wxXPMDecoder::ReadData(const char* const* xpm_data) in wxWidgets-2.8.10\src\comm...
by !here&!there
Tue Jun 30, 2009 2:26 am
Forum: Compiler / Linking / IDE Related
Topic: Debugging App in Visual Studion 2008 Express very slow
Replies: 6
Views: 563

ok, i have done that and it seems that creating icons, images, wxBitmapButton and wxBitmap is causing that. The following code takes 10 secondes to finish, and it is repeated 3 times, so 3 x 10 = 30 secondes to load notebook with images: wxBitmapButton* bmpButton = new wxBitmapButton(this, ID_AUI_BM...
by !here&!there
Mon Jun 29, 2009 5:53 pm
Forum: Compiler / Linking / IDE Related
Topic: Debugging App in Visual Studion 2008 Express very slow
Replies: 6
Views: 563

I have :

- 8 32x32 xpm images, used to represent small icons.

- 11 128x128 xpm images, used as custom wxPanel background images.


Please note, that the "slow loading" is occuring only at first time creation.

you'll need to do some "profiling"
Sorry, i didn't understand :oops:
by !here&!there
Mon Jun 29, 2009 3:57 pm
Forum: Compiler / Linking / IDE Related
Topic: Debugging App in Visual Studion 2008 Express very slow
Replies: 6
Views: 563

Debugging App in Visual Studion 2008 Express very slow

Hi, i have two issues while debugging my application( simple desktop application ) in VS 2008 : 1.)when i start debugging( f5 ) it takes about 12-14 secondes to load the application. 2.)In my application, i have a button labeled"Options"; if the User clicks it, it should display a (wxAuiMDIParentFra...
by !here&!there
Mon May 18, 2009 3:45 pm
Forum: General Development
Topic: Connecting wxCheckbox to wxEVT_ENTER_WINDOW
Replies: 3
Views: 888

Re: Connecting wxCheckbox to wxEVT_ENTER_WINDOW

Hi, It may work but it's wrong ;) what is wrong with it? i am calling MyCheckbox1->Connect( wxEVT_ENTER_WINDOW, wxMouseEventHandler(MyPanel::OnEnter) ); inside MyPanel->Create() Thanks for this hint See the recursive connect example here : http://wiki.wxwidgets.org/Catching_key_events_globally#Recur...
by !here&!there
Sun May 17, 2009 6:13 pm
Forum: General Development
Topic: What flow of programming and tools do you use?
Replies: 38
Views: 28908

Here is my list:

IDE: VS2008 Express
Dialogs: Some times hand coded or with wxForumBuilder
Documentation: Helpmaker
Installer: Inno
Translation: Poedit
Packer: UPX
Icons&Images: GIMP
Distribution: Sourceforge
by !here&!there
Sun May 17, 2009 5:24 pm
Forum: General Development
Topic: Connecting wxCheckbox to wxEVT_ENTER_WINDOW
Replies: 3
Views: 888

Connecting wxCheckbox to wxEVT_ENTER_WINDOW

Hello, i have a wxPanel which contains 27 wxCheckbox controls. I am trying to catch wxMouseEvent upon entering each checkbox. The following Code works : MyCheckbox1->Connect( wxEVT_ENTER_WINDOW, wxMouseEventHandler(MyPanel::OnEnter) ); Is it there any way to connect all the 27 checkboxes with one Co...